summaryrefslogtreecommitdiff
path: root/net-analyzer/fail2ban
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/Manifest4
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.11.2.ebuild111
-rw-r--r--net-analyzer/fail2ban/fail2ban-99999999.ebuild2
3 files changed, 115 insertions, 2 deletions
diff --git a/net-analyzer/fail2ban/Manifest b/net-analyzer/fail2ban/Manifest
index 5598922002f6..b0bba48e9b06 100644
--- a/net-analyzer/fail2ban/Manifest
+++ b/net-analyzer/fail2ban/Manifest
@@ -1,4 +1,6 @@
DIST fail2ban-0.11.1.tar.gz 538660 BLAKE2B c88765ac3f49c19e0570248891814c647f2c3515290982de21c7b6c377508189fa53182fca84d62f61b231e250395992e8cf06cc61394dd41150f02d8a254f8b SHA512 019b088aa6375f98742ed101ef6f65adabca3324444d71d5b8597a8d1d22fa76b9f503660f0498643fe24a3b8e4368de916072a1ab77b8e2ea3eda41c3e0c8c6
+DIST fail2ban-0.11.2.tar.gz 559552 BLAKE2B 0c61c1d5f6eb23d585533fbb84e69343cb305df188537a97002489318292c6056447c4c221c9d4d4cde6cca52f0c2fb877b597957f703e4d6707801a646e52b0 SHA512 46b27abd947b00ea64106dbac563ef8afef38eec86684024d47d9a0e8c1969ff864ad6df7f4f8de2aa3eb1af6d769fb6796592d9f0e35521d5f95f17b8cade97
EBUILD fail2ban-0.11.1-r2.ebuild 3304 BLAKE2B bd423b357180362b03a602e661c348440f559af0007acaebd3b87fac825b66ed5a2f9d87f72c83a59f460d31ff88d0fab9dc58be1fdf15f2a77bb6753ad26ff8 SHA512 a0b3ac50485c7d74b0a2865ac90858fb9ddfc7b5a61902e22b21187e01e9a8f15e230983353d5998d9bb4f20cc4fd1f5dcc5986dab7d4acf8bac329e8a295ca8
-EBUILD fail2ban-99999999.ebuild 3231 BLAKE2B 3700cf6551941dd695e81145d723f6be91bf21df0ac3fe95c3245a4a954c9855e3d082e47409f9a75dbbb87fc1c4ecf51a6477b3e419987a669ce821ee47e7fa SHA512 dc518092d1b9687ffe1c2d47e5e23f3ed58cd36b7ed28fc14db9179476c99b208450ba9f8fb0e9c516320408da526ae74f18ca1efb21a0b14cff4d06b9578a7c
+EBUILD fail2ban-0.11.2.ebuild 3357 BLAKE2B 9c7a838c885ba4a1d976d9433dcc1c084322e94a989a8f14eaa27e80a87ae84a2c9ce154f56e8629b9f5f4770e6ea2688d29550f5c0253ffb27ed2295acab295 SHA512 b22ad2a16221b97bd927769694ba9d90d0f751b2b0156811866dd52bed1c7b19d8e2d9c805cbd3ccd16dba526802ab90e3a9fcd6acb8d638a0ba81b205059f21
+EBUILD fail2ban-99999999.ebuild 3235 BLAKE2B 68151b88460a56e1caa151bfe38a5e5f8e3338ef9c3d67e80463d4cada9036656b48c896c7fe88eb7f60ef6122f2921cf3472abe3676d07be32ec3ad65469cc7 SHA512 c51672b159da9332469c04b92b7e94deb7c87346aabc011ecf6a2fbbc600df6cebfb4e1eab5525a459903f30335ce20da466d79f56f20ea3d02b6562d4bac261
MISC metadata.xml 372 BLAKE2B 7fca866187d9a128e6fb6787a4099d7a6442e0e51e558786773b91c3e2f06e67167d76f9bc96be0fe1baa1c44fc3f0e9e2105a327a10cb2720b3e3f9e4303a66 SHA512 4d5710e2fb4a7c353ca6bd3203bceef57d4d004367993dc1044800ee8713a3f4697fe8ba3472a73ecd015503656dfb7cd68d674c99188ce5702769cfeaf06b25
diff --git a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
new file mode 100644
index 000000000000..bd35827ae05e
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit bash-completion-r1 distutils-r1 systemd
+
+DESCRIPTION="scans log files and bans IPs that show malicious signs"
+HOMEPAGE="https://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux systemd"
+# Needs some work to enable them right now
+RESTRICT="test"
+
+RDEPEND="
+ virtual/logger
+ virtual/mta
+ selinux? ( sec-policy/selinux-fail2ban )
+ systemd? ( $(python_gen_cond_dep '|| (
+ dev-python/python-systemd[${PYTHON_MULTI_USEDEP}]
+ sys-apps/systemd[python(-),${PYTHON_MULTI_USEDEP}]
+ )' 'python*' ) )
+"
+
+DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
+
+python_prepare_all() {
+ default
+
+ # Replace /var/run with /run, but not in the top source directory
+ find . -mindepth 2 -type f -exec \
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
+
+ sed -i -e 's|runscript|openrc-run|g' files/gentoo-initd || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ ./fail2ban-2to3 || die
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run || die
+
+ # not FILESDIR
+ newconfd files/gentoo-confd ${PN}
+ newinitd files/gentoo-initd ${PN}
+ sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
+ systemd_dounit "${T}/${PN}.service"
+ systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ doman man/*.{1,5}
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins files/${PN}-logrotate ${PN}
+
+ keepdir /var/lib/${PN}
+
+ newbashcomp files/bash-completion ${PN}-client
+ bashcomp_alias ${PN}-client ${PN}-server ${PN}-regex
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+
+ if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+
+ if ! has_version dev-lang/python[sqlite]; then
+ elog "If you want to use ${PN}'s persistent database, then reinstall"
+ elog "dev-lang/python with USE=sqlite. If you do not use the"
+ elog "persistent database feature, then you should set"
+ elog "dbfile = :memory: in fail2ban.conf accordingly."
+ fi
+
+ if has_version sys-apps/systemd[-python]; then
+ elog "If you want to track logins through sys-apps/systemd's"
+ elog "journal backend, then reinstall sys-apps/systemd with USE=python"
+ fi
+}
diff --git a/net-analyzer/fail2ban/fail2ban-99999999.ebuild b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
index 358d12b3149a..ab7e2cb0ad8f 100644
--- a/net-analyzer/fail2ban/fail2ban-99999999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_SINGLE_IMPL=1
inherit bash-completion-r1 distutils-r1 git-r3 systemd