summaryrefslogtreecommitdiff
path: root/net-analyzer/fail2ban/fail2ban-99999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-99999999.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-99999999.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-99999999.ebuild b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
index d4e1f1886dc8..1618b1f20e24 100644
--- a/net-analyzer/fail2ban/fail2ban-99999999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+PYTHON_COMPAT=( python{2_7,3_6} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 git-r3 systemd
+inherit bash-completion-r1 distutils-r1 git-r3 systemd
DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
@@ -25,7 +25,7 @@ RDEPEND="
sys-apps/systemd[python(-),${PYTHON_USEDEP}]
)' 'python*' ) )
"
-REQUIRED_USE="systemd? ( !python_single_target_pypy )"
+
RESTRICT="test"
DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
@@ -41,6 +41,13 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_compile() {
+ if python_is_python3; then
+ ./fail2ban-2to3 || die
+ fi
+ distutils-r1_python_compile
+}
+
python_install_all() {
distutils-r1_python_install_all
@@ -49,8 +56,8 @@ python_install_all() {
# not FILESDIR
newconfd files/gentoo-confd ${PN}
newinitd files/gentoo-initd ${PN}
- sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}"/${PN}.service || die
- systemd_dounit "${T}"/${PN}.service
+ sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
+ systemd_dounit "${T}/${PN}.service"
systemd_dotmpfilesd files/${PN}-tmpfiles.conf
doman man/*.{1,5}
@@ -60,6 +67,9 @@ python_install_all() {
newins files/${PN}-logrotate ${PN}
keepdir /var/lib/${PN}
+
+ newbashcomp files/bash-completion ${PN}-client
+ bashcomp_alias ${PN}-client ${PN}-server ${PN}-regex
}
pkg_preinst() {