summaryrefslogtreecommitdiff
path: root/net-analyzer/ethloop/ethloop-10-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ethloop/ethloop-10-r3.ebuild')
-rw-r--r--net-analyzer/ethloop/ethloop-10-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/ethloop/ethloop-10-r3.ebuild b/net-analyzer/ethloop/ethloop-10-r3.ebuild
new file mode 100644
index 000000000000..d49ae392f80f
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/ethloop/ethloop10.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin ethloop
+}