summaryrefslogtreecommitdiff
path: root/net-analyzer/alive/alive-2.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/alive/alive-2.0.2-r1.ebuild')
-rw-r--r--net-analyzer/alive/alive-2.0.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/alive/alive-2.0.2-r1.ebuild b/net-analyzer/alive/alive-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..9ee866d5fd4c
--- /dev/null
+++ b/net-analyzer/alive/alive-2.0.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="a periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+COMMON_DEPEND="
+ net-misc/iputils
+"
+DEPEND="
+ app-arch/xz-utils
+ ${COMMON_DEPEND}
+"
+RDEPEND="
+ dev-scheme/guile
+ ${COMMON_DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-ping-test.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}