summaryrefslogtreecommitdiff
path: root/media-video/x264-encoder/x264-encoder-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/x264-encoder/x264-encoder-9999.ebuild')
-rw-r--r--media-video/x264-encoder/x264-encoder-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/media-video/x264-encoder/x264-encoder-9999.ebuild b/media-video/x264-encoder/x264-encoder-9999.ebuild
index 2596cb3a87e1..f9d72081e46e 100644
--- a/media-video/x264-encoder/x264-encoder-9999.ebuild
+++ b/media-video/x264-encoder/x264-encoder-9999.ebuild
@@ -12,10 +12,10 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://code.videolan.org/videolan/x264.git"
SRC_URI=""
else
- MY_P="x264-snapshot-$(ver_cut 3)-2245"
- SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ # Download https://code.videolan.org/videolan/x264/-/archive/master/x264-master.tar.bz2
+ SRC_URI="https://dev.gentoo.org/~aballier/distfiles/x264-${PV}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
- S="${WORKDIR}/${MY_P}"
+ S="${WORKDIR}/x264-master"
fi
LICENSE="GPL-2"
@@ -36,8 +36,6 @@ DEPEND="${RDEPEND}
x86? ( ${ASM_DEP} )"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/gpac.patch" )
-
src_configure() {
tc-export CC