summaryrefslogtreecommitdiff
path: root/media-video/webcamoid/webcamoid-9.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/webcamoid/webcamoid-9.1.1.ebuild')
-rw-r--r--media-video/webcamoid/webcamoid-9.1.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-video/webcamoid/webcamoid-9.1.1.ebuild b/media-video/webcamoid/webcamoid-9.1.1.ebuild
index c539d8831d38..012242abe5a0 100644
--- a/media-video/webcamoid/webcamoid-9.1.1.ebuild
+++ b/media-video/webcamoid/webcamoid-9.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="Full featured webcam capture application"
HOMEPAGE="https://webcamoid.github.io"
@@ -52,6 +52,11 @@ RDEPEND="${COMMON_DEPEND}
"
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/927104
+ # https://github.com/webcamoid/webcamoid/issues/702
+ filter-lto
+
#Disable git in package source. If not disabled the cmake configure process will show
#a lot of "fatal not a git repository" errors
sed -i 's|find_program(GIT_BIN git)|#find_program(GIT_BIN git)|' libAvKys/cmake/ProjectCommons.cmake || die