summaryrefslogtreecommitdiff
path: root/media-video/vdr/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vdr/files')
-rw-r--r--media-video/vdr/files/vdr-2.4.6_clang.patch20
-rw-r--r--media-video/vdr/files/vdr-2.4.6_remove_plugins.patch24
2 files changed, 20 insertions, 24 deletions
diff --git a/media-video/vdr/files/vdr-2.4.6_clang.patch b/media-video/vdr/files/vdr-2.4.6_clang.patch
new file mode 100644
index 000000000000..095bd18ae200
--- /dev/null
+++ b/media-video/vdr/files/vdr-2.4.6_clang.patch
@@ -0,0 +1,20 @@
+compiling with CC="clang" CXX="clang++" we get the message
+
+ svdrp.c:76:3: error: no matching member function for call to 'Set'
+ Set(INADDR_ANY, 0);
+ ^~~
+
+this patch fixes it
+
+Signed-off-by: Martin Dummer <martin.dummer@gmx.net> ( 2020/02/15 )
+--- a/svdrp.c 2021-02-14 00:00:30.417157252 +0100
++++ b/svdrp.c 2021-02-14 00:00:55.636995544 +0100
+@@ -73,7 +73,7 @@
+
+ cIpAddress::cIpAddress(void)
+ {
+- Set(INADDR_ANY, 0);
++ Set((const char *)INADDR_ANY, 0);
+ }
+
+ cIpAddress::cIpAddress(const char *Address, int Port)
diff --git a/media-video/vdr/files/vdr-2.4.6_remove_plugins.patch b/media-video/vdr/files/vdr-2.4.6_remove_plugins.patch
deleted file mode 100644
index d2571ea687c8..000000000000
--- a/media-video/vdr/files/vdr-2.4.6_remove_plugins.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-we do not install any plugins from core vdr
-
-Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> 2021/Feb/11
-diff -Naur vdr-2.4.6.orig/Makefile vdr-2.4.6/Makefile
---- vdr-2.4.6.orig/Makefile 2020-06-27 11:13:04.000000000 +0200
-+++ vdr-2.4.6/Makefile 2020-08-08 18:16:02.519719542 +0200
-@@ -136,7 +136,7 @@
- VDRVERSION = $(shell sed -ne '/define VDRVERSION/s/^.*"\(.*\)".*$$/\1/p' config.h)
- APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' config.h)
-
--all: vdr i18n plugins
-+all: vdr i18n
-
- # Implicit rules:
-
-@@ -282,7 +282,7 @@
-
- # Install the files (note that 'install-pc' must be first!):
-
--install: install-pc install-bin install-conf install-doc install-plugins install-i18n install-includes
-+install: install-pc install-bin install-conf install-doc install-i18n install-includes
-
- # VDR binary:
-