summaryrefslogtreecommitdiff
path: root/media-video/vcdimager/vcdimager-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vcdimager/vcdimager-2.0.1.ebuild')
-rw-r--r--media-video/vcdimager/vcdimager-2.0.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-video/vcdimager/vcdimager-2.0.1.ebuild b/media-video/vcdimager/vcdimager-2.0.1.ebuild
new file mode 100644
index 000000000000..0eed4a6d6233
--- /dev/null
+++ b/media-video/vcdimager/vcdimager-2.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="GNU VCDimager"
+HOMEPAGE="https://www.gnu.org/software/vcdimager/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs +xml"
+
+RDEPEND="
+ >=dev-libs/libcdio-2.0.0:0=[-minimal,${MULTILIB_USEDEP}]
+ dev-libs/popt
+ xml? ( dev-libs/libxml2:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+DOCS=( AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+PATCHES=("${FILESDIR}/${P}-pkg-config.patch")
+
+src_prepare() {
+ default
+
+ # Avoid building useless programs. Bug #226249
+ sed -i \
+ -e 's/check_PROGRAMS =/check_PROGRAMS +=/' \
+ -e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
+ test/Makefile.am || die
+ sed -i \
+ -e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
+ example/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ multilib_is_native_abi || myeconfargs+=( --without-cli-frontend )
+ if ! use xml || ! multilib_is_native_abi ; then
+ myeconfargs+=( --without-xml-frontend )
+ fi
+
+ ECONF_SOURCE="${S}" \
+ econf ${myeconfargs[@]}
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ einstalldocs
+}