summaryrefslogtreecommitdiff
path: root/media-video/super_demux/super_demux-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/super_demux/super_demux-0.3.ebuild')
-rw-r--r--media-video/super_demux/super_demux-0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-video/super_demux/super_demux-0.3.ebuild b/media-video/super_demux/super_demux-0.3.ebuild
new file mode 100644
index 000000000000..9e79e39bedcb
--- /dev/null
+++ b/media-video/super_demux/super_demux-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="DVB transport stream TS to ES demultiplexer"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.diff"
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin super_demux
+ dodoc CHANGES README
+}