summaryrefslogtreecommitdiff
path: root/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild')
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
index 337ba993d166..5c2e985195d7 100644
--- a/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
inherit cmake-multilib flag-o-matic xdg
@@ -21,7 +21,7 @@ else
fi
SLOT="0"
-IUSE="+asm jack mp3 pulseaudio theora v4l vorbis vpx x264"
+IUSE="+asm jack mp3 opengl pulseaudio theora v4l vorbis vpx x264"
RDEPEND="
dev-qt/qtcore:5
@@ -29,7 +29,6 @@ RDEPEND="
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
media-libs/alsa-lib:0=
- media-libs/libglvnd[${MULTILIB_USEDEP},X]
media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXext
@@ -39,17 +38,20 @@ RDEPEND="
virtual/glu[${MULTILIB_USEDEP}]
v4l? ( media-libs/libv4l )
jack? ( virtual/jack )
+ opengl? ( media-libs/libglvnd[${MULTILIB_USEDEP},X] )
pulseaudio? ( media-sound/pulseaudio )
"
DEPEND="${RDEPEND}"
BDEPEND="dev-qt/linguist-tools:5"
+REQUIRED_USE="abi_x86_32? ( opengl )"
+
pkg_pretend() {
- if [[ "${ABI}" == amd64 ]]; then
- elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
- elog "When added 32bit GLInject libraries are also included. This is"
- elog "required if you want to use OpenGL recording on 32bit applications."
- elog
+ if [[ "${ABI}" == amd64 ]] ; then
+ einfo "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ einfo "When added 32bit GLInject libraries are also included. This is"
+ einfo "required if you want to use OpenGL recording on 32bit applications."
+ einfo
fi
if has_version media-video/ffmpeg[x264] && has_version media-libs/x264[10bit] ; then
@@ -78,9 +80,10 @@ multilib_src_configure() {
local mycmakeargs=(
-DENABLE_JACK_METADATA="$(multilib_native_usex jack)"
-DENABLE_X86_ASM="$(usex asm)"
+ -DWITH_OPENGL_RECORDING="$(usex opengl)"
-DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)"
-DWITH_JACK="$(multilib_native_usex jack)"
- -DWITH_GLINJECT="true"
+ -DWITH_GLINJECT="$(usex opengl)"
-DWITH_V4L2="$(multilib_native_usex v4l)"
)