summaryrefslogtreecommitdiff
path: root/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch')
-rw-r--r--media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch b/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch
new file mode 100644
index 000000000000..39af16be2719
--- /dev/null
+++ b/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 75d85f0..15e6bc1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,6 @@
+ cmake_minimum_required(VERSION 3.5)
+ project(obs-v4l2sink)
++include(GNUInstallDirs)
+
+
+ include(external/FindLibObs.cmake)
+@@ -44,8 +45,8 @@ endif()
+ set_target_properties(v4l2sink PROPERTIES PREFIX "")
+
+ install(TARGETS v4l2sink
+- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/obs-plugins)
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/obs-plugins)
+
+ install(DIRECTORY locale/
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/obs/obs-plugins/v4l2sink/locale")
++ DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/obs/obs-plugins/v4l2sink/locale")
+