summaryrefslogtreecommitdiff
path: root/media-video/obs-studio
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/obs-studio')
-rw-r--r--media-video/obs-studio/Manifest6
-rw-r--r--media-video/obs-studio/obs-studio-23.0.1.ebuild8
-rw-r--r--media-video/obs-studio/obs-studio-23.1.0.ebuild129
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild8
4 files changed, 141 insertions, 10 deletions
diff --git a/media-video/obs-studio/Manifest b/media-video/obs-studio/Manifest
index 9a8eed59297b..9b9d4690bdfa 100644
--- a/media-video/obs-studio/Manifest
+++ b/media-video/obs-studio/Manifest
@@ -1,4 +1,6 @@
DIST obs-studio-23.0.1.tar.gz 6223214 BLAKE2B c3b65ad9134aefc36a3fa33b8d185a1ee76f76c10edd30d5ad8a7af86605c4e7b3b8d83c5570203d926655131f7c20f4ef11dcbf55c7af745efc2b68d4933c54 SHA512 6877d4bf635a9769d634683a85075a5fe3a5de1fcc83882647dfbc379a897eee05b69c2159e290ff73f53aa7c03027ea4ea15e1169de57c2c50f4e504eff410f
-EBUILD obs-studio-23.0.1.ebuild 3012 BLAKE2B 5a19f9b6daa0523ef9fe912cb8cbcba3c3b7cbcd714ddfaf41200246fa27f9b4c9c021c096994ed8cadb52dbabe4cb05148a39dc2632c14ceb85c87e3c19d5a0 SHA512 76f6cd30b54f98d732e8cca4bff4fb476435319c44e706ae621c2e7d17bc620a1e784c893c5bb6a79dcaf7a6f3476a604418f855a3dc5d4e0087049d428a64e0
-EBUILD obs-studio-9999.ebuild 2981 BLAKE2B 532a7a5ac6d7db36e6c0e8217310fbd891ed2e24fd1873a7e327d60256e0ed41bfcc33371d2d2ef5669786002b7900a113b62006457ea3405492bab2bd2eb2e4 SHA512 a9885c2461dd79a62410c9de6e2e03428e4345d9bc75a077edadf44e61c558fa75d55d6eae0b98f83a622e8a08b3dbe5a5d6ab3aeb5eed8a8fb65a1aeaafa6a0
+DIST obs-studio-23.1.0.tar.gz 6192139 BLAKE2B 8c85d21f68b0dc799a8fdfce3ff94d837d0e02bfa55606eec9985d2c2d1c3d9ae78664ba8b17f393abb197f1595fa0f78f314fe474883a81166d9c6a0967682c SHA512 ab4f71430ae314774afbba8b8e39c4eb35ab147d49d6d33b188e7a820b1198ccbb6005fad111502834652b5261b88d07c075094a8303ea7294da3171e8e015bb
+EBUILD obs-studio-23.0.1.ebuild 2999 BLAKE2B 967cca610af94878444107a34cad25854e8f1b6d15bf68e7d4390ac069a47beb2a21564a56cd3896f76f1d3314fefb50922915ec79fa074fa5850931e4bc74c3 SHA512 f119490d232ab884b2f7098522bd6c25a367f24c124f0ebca4ad24984dafe3b66d4c6df66f64e002f5f27516388a3d9d5dbaf1511607dbf5cae105fe3aaa30a8
+EBUILD obs-studio-23.1.0.ebuild 2999 BLAKE2B 967cca610af94878444107a34cad25854e8f1b6d15bf68e7d4390ac069a47beb2a21564a56cd3896f76f1d3314fefb50922915ec79fa074fa5850931e4bc74c3 SHA512 f119490d232ab884b2f7098522bd6c25a367f24c124f0ebca4ad24984dafe3b66d4c6df66f64e002f5f27516388a3d9d5dbaf1511607dbf5cae105fe3aaa30a8
+EBUILD obs-studio-9999.ebuild 2968 BLAKE2B b2f56667f1c126858086b8f4a6b1cab518e923d26f9a46869875139f1b1b25f773d331fa3e450b309c9fdfb8b9cd104640f5ca03a8e7fa5b054f9433a07f8419 SHA512 84044f248fa0195a94a92c41d6cdaf66b1574d947aaa5e40e9eeac9054fc9b57c07661780472d3679b991002e45f25c9aa2dd16f16864e9aa69a68951394ce49
MISC metadata.xml 1122 BLAKE2B 608bff24775bd69702b19d9b1db4260ed1e5bf7d932f917d3a27d284a791374211c7fec019bd3a742552cf11142df3d2a4877d81645244bc81a6df5e60ae9f71 SHA512 29291de223d1d70f78b419c05fec1cca18e8dcd52ed5619dff51a130f9e064369378e9e803f3dd5e7c86c9f505ae506917ec04e2c9adadfcc1a23c9aeb27192f
diff --git a/media-video/obs-studio/obs-studio-23.0.1.ebuild b/media-video/obs-studio/obs-studio-23.0.1.ebuild
index ef63ca589b65..6ee58e5d0a11 100644
--- a/media-video/obs-studio/obs-studio-23.0.1.ebuild
+++ b/media-video/obs-studio/obs-studio-23.0.1.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-inherit cmake-utils gnome2-utils python-single-r1
+inherit cmake-utils python-single-r1 xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -103,7 +103,7 @@ src_configure() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
if ! use alsa && ! use pulseaudio; then
elog
@@ -125,5 +125,5 @@ pkg_postinst() {
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
diff --git a/media-video/obs-studio/obs-studio-23.1.0.ebuild b/media-video/obs-studio/obs-studio-23.1.0.ebuild
new file mode 100644
index 000000000000..6ee58e5d0a11
--- /dev/null
+++ b/media-video/obs-studio/obs-studio-23.1.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit cmake-utils python-single-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Software for Recording and Streaming Live Video Content"
+HOMEPAGE="https://obsproject.com"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex truetype v4l"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ luajit? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+"
+DEPEND="
+ >=dev-libs/jansson-2.5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/ffmpeg:=[x264]
+ net-misc/curl
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ fdk? ( media-libs/fdk-aac:= )
+ imagemagick? ( media-gfx/imagemagick:= )
+ jack? ( virtual/jack )
+ luajit? ( dev-lang/luajit:2 )
+ nvenc? (
+ || (
+ <media-video/ffmpeg-4[nvenc]
+ >=media-video/ffmpeg-4[video_cards_nvidia]
+ )
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( ${PYTHON_DEPS} )
+ speex? ( media-libs/speexdsp )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ v4l? ( media-libs/libv4l )
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DDISABLE_ALSA=$(usex !alsa)
+ -DDISABLE_FREETYPE=$(usex !truetype)
+ -DDISABLE_JACK=$(usex !jack)
+ -DDISABLE_LIBFDK=$(usex !fdk)
+ -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+ -DDISABLE_SPEEXDSP=$(usex !speex)
+ -DDISABLE_V4L2=$(usex !v4l)
+ -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+ -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
+ -DOBS_VERSION_OVERRIDE=${PV}
+ -DUNIX_STRUCTURE=1
+ )
+
+ if use luajit || use python; then
+ mycmakeargs+=(
+ -DDISABLE_LUA=$(usex !luajit)
+ -DDISABLE_PYTHON=$(usex !python)
+ -DENABLE_SCRIPTING=yes
+ )
+ else
+ mycmakeargs+=( -DENABLE_SCRIPTING=no )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if ! use alsa && ! use pulseaudio; then
+ elog
+ elog "For the audio capture features to be available,"
+ elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
+ elog "be enabled."
+ elog
+ fi
+
+ if ! has_version "sys-apps/dbus"; then
+ elog
+ elog "The 'sys-apps/dbus' package is not installed, but"
+ elog "could be used for disabling hibernating, screensaving,"
+ elog "and sleeping. Where it is not installed,"
+ elog "'xdg-screensaver reset' is used instead"
+ elog "(if 'x11-misc/xdg-utils' is installed)."
+ elog
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index abb6a6df16e0..34dfcfd0ddaf 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-inherit cmake-utils gnome2-utils python-single-r1
+inherit cmake-utils python-single-r1 xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -102,7 +102,7 @@ src_configure() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
if ! use alsa && ! use pulseaudio; then
elog
@@ -124,5 +124,5 @@ pkg_postinst() {
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}