summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index a7b00cd2fc59..0f9e5d85df07 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -250,7 +250,22 @@ src_configure() {
src_test() {
# https://github.com/mpv-player/mpv/blob/master/DOCS/man/options.rst#debugging
- edo "${BUILD_DIR}"/mpv --no-config -v --unittest=all-simple
+ local tests=($("${BUILD_DIR}"/mpv --no-config --unittest=help | tail -n +2; assert))
+ (( ${#tests[@]} )) || die "failed to gather any tests"
+
+ local skip=(
+ all-simple
+
+ # fails on non-issue minor inconsistencies (bug #888639)
+ img_format
+ repack_sws
+ )
+
+ local test
+ for test in "${tests[@]}"; do
+ [[ ${test} == @($(IFS='|'; echo "${skip[*]}")) ]] ||
+ edo "${BUILD_DIR}"/mpv -v --no-config --unittest="${test}"
+ done
}
src_install() {