summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index d4a50dfa75a3..61db0d2cd470 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
PYTHON_REQ_USE='threads(+)'
WAF_PV=2.0.9
@@ -97,7 +97,7 @@ COMMON_DEPEND="
vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
vdpau? ( x11-libs/libvdpau )
vulkan? (
- media-libs/libplacebo[vulkan]
+ media-libs/libplacebo:=[vulkan]
media-libs/shaderc
)
wayland? (
@@ -123,9 +123,9 @@ COMMON_DEPEND="
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
virtual/pkgconfig
- cuda? ( >=media-libs/nv-codec-headers-8.1.24.1 )
- doc? ( dev-python/docutils
- dev-python/rst2pdf )
+ dev-python/docutils
+ cuda? ( >=media-libs/nv-codec-headers-8.2.15.7 )
+ doc? ( dev-python/rst2pdf )
dvb? ( virtual/linuxtv-dvb-headers )
test? ( >=dev-util/cmocka-1.0.0 )
"
@@ -166,7 +166,7 @@ src_configure() {
$(use_enable doc html-build)
$(use_enable doc pdf-build)
- $(use_enable doc manpage-build)
+ --enable-manpage-build
$(use_enable cplugins)
$(use_enable test)
@@ -253,9 +253,9 @@ src_configure() {
--disable-egl-android
--disable-uwp
--disable-audiounit
+ --disable-macos-media-player
--disable-wasapi
--disable-ios-gl
- --disable-apple-remote
--disable-macos-touchbar
--disable-macos-cocoa-cb
--disable-tvos