summaryrefslogtreecommitdiff
path: root/media-video/jubler/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/jubler/files')
-rw-r--r--media-video/jubler/files/jubler-4.6.1-ffmpeg-1.patch274
-rw-r--r--media-video/jubler/files/jubler-4.6.1-ffmpeg-2.patch37
-rw-r--r--media-video/jubler/files/jubler-4.6.1-gentoo.patch163
3 files changed, 0 insertions, 474 deletions
diff --git a/media-video/jubler/files/jubler-4.6.1-ffmpeg-1.patch b/media-video/jubler/files/jubler-4.6.1-ffmpeg-1.patch
deleted file mode 100644
index 18df9069d198..000000000000
--- a/media-video/jubler/files/jubler-4.6.1-ffmpeg-1.patch
+++ /dev/null
@@ -1,274 +0,0 @@
-Index: Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeaudio.c
-===================================================================
---- Jubler-4.6.1.orig/resources/ffmpeg/ffdecode/decodeaudio.c
-+++ Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeaudio.c
-@@ -67,19 +67,19 @@ jboolean decodeAudio(JNIEnv * env, jobje
- AVStream *audio_st=NULL;
- int got_audio, len, err=0, audio_index=-1, i=0, pack_duration=0, packsize=0, codec_is_open=-1, video_index=-1, codec_enc_is_open=-1;
- jlong pack_pts=0;
-- char *outbuf=NULL;
-+ AVFrame *outbuf=NULL;
- unsigned char *packptr;
- jboolean ret = JNI_TRUE, nobrk = JNI_TRUE;
-
- av_register_all();
-
- /* Open the input/output files */
-- err = av_open_input_file(&fcx, input_filename, NULL, 0, NULL);
-+ err = avformat_open_input(&fcx, input_filename, NULL, NULL);
- if(err<0){
- DEBUG(env, this, "decodeAudio", "Could not open file '%s'.", input_filename);
- ret = JNI_FALSE;
- }
-- outbuf = malloc(AVCODEC_MAX_AUDIO_FRAME_SIZE);
-+ outbuf = avcodec_alloc_frame();
- if(outbuf==NULL) {
- DEBUG(env, this, "decodeAudio", "Could not allocate memory for outbuf.");
- ret = JNI_FALSE;
-@@ -129,7 +129,7 @@ jboolean decodeAudio(JNIEnv * env, jobje
- }
- else {
- /* open it */
-- if ((codec_is_open = avcodec_open(ccx, codec)) < 0) {
-+ if ((codec_is_open = avcodec_open2(ccx, codec, NULL)) < 0) {
- DEBUG(env, this, "decodeAudio", "Could not open codec.");
- ret = JNI_FALSE;
- }
-@@ -158,10 +158,10 @@ jboolean decodeAudio(JNIEnv * env, jobje
- }
-
- /* use wav as the output format of the file */
-- fmt = guess_format(NULL, output_filename, NULL);
-+ fmt = av_guess_format(NULL, output_filename, NULL);
- if (!fmt) {
- DEBUG(env, this, "decodeAudio", "Could not deduce output format from file extension: using WAV.");
-- fmt = guess_format("wav", NULL, NULL);
-+ fmt = av_guess_format("wav", NULL, NULL);
- }
- if (!fmt) {
- DEBUG(env, this, "decodeAudio", "Could not find suitable output format.");
-@@ -182,35 +182,28 @@ jboolean decodeAudio(JNIEnv * env, jobje
- audio_st = add_audio_stream(env, this, ofcx, fmt->audio_codec, ccx->sample_rate, ccx->channels);
- }
-
-- /* set the output parameters (must be done even if no parameters) */
-- if (av_set_parameters(ofcx, NULL) < 0) {
-- DEBUG(env, this, "decodeAudio", "Invalid output format parameters.");
-- ret = JNI_FALSE;
-- }
-- else {
- codec_enc = avcodec_find_encoder(audio_st->codec->codec_id);
- if (!codec_enc) {
- DEBUG(env, this, "decodeAudio", "Encoder codec not found.");
- ret = JNI_FALSE;
- }
- else {
-- if ((codec_enc_is_open = avcodec_open(audio_st->codec, codec_enc)) < 0) {
-+ if ((codec_enc_is_open = avcodec_open2(audio_st->codec, codec_enc, NULL)) < 0) {
- DEBUG(env, this, "decodeAudio", "Could not open encoder codec.");
- ret = JNI_FALSE;
- }
- else {
- if (!(fmt->flags & AVFMT_NOFILE)) {
-- if (url_fopen(&ofcx->pb, output_filename, URL_WRONLY) < 0) {
-+ if (avio_open(&ofcx->pb, output_filename, AVIO_FLAG_WRITE) < 0) {
- DEBUG(env, this, "decodeAudio", "Could not open file '%s'", output_filename);
- ret = JNI_FALSE;
- }
- else {
-- av_write_header(ofcx);
-+ avformat_write_header(ofcx,NULL);
- }
- }
- }
- }
-- }
- }
- }
- else {
-@@ -243,7 +236,7 @@ jboolean decodeAudio(JNIEnv * env, jobje
- ccx->request_channels = 2;
- }
- got_audio = AVCODEC_MAX_AUDIO_FRAME_SIZE;
-- len = avcodec_decode_audio2(ccx, (short *)outbuf, &got_audio, packptr, packsize);
-+ len = avcodec_decode_audio4(ccx, outbuf, &got_audio, &pkt);
-
- if (len < 0) {
- DEBUG(env, this, "decodeAudio", "Error while decoding.");
-@@ -258,7 +251,7 @@ jboolean decodeAudio(JNIEnv * env, jobje
- * this is the frame we want */
- if (pack_pts >= seek_time_start) {
- /* if a frame has been decoded, output it */
-- audio_enc_out(env, this, ofcx, audio_st, (short *)outbuf, got_audio);
-+ audio_enc_out(env, this, ofcx, audio_st, (short *)(outbuf->data[0]), av_samples_get_buffer_size(NULL, ccx->channels, outbuf->nb_samples, ccx->sample_fmt, 1));
- /* if the next frame gets past our stop time, we want to stop decoding */
- if ( pack_pts + pack_duration > seek_time_stop ) {
- av_free_packet(&pkt);
-@@ -269,7 +262,7 @@ jboolean decodeAudio(JNIEnv * env, jobje
- /* If the next frame will be past our start seek time, this is the frame we want */
- else if (pack_pts + pack_duration > seek_time_start) {
- /* if a frame has been decoded, output it */
-- audio_enc_out(env, this, ofcx, audio_st, (short *)outbuf, got_audio);
-+ audio_enc_out(env, this, ofcx, audio_st, (short *)(outbuf->data[0]), av_samples_get_buffer_size(NULL, ccx->channels, outbuf->nb_samples, ccx->sample_fmt, 1));
- /* if the next frame gets past our stop time, we want to stop decoding */
- if ( pack_pts + pack_duration > seek_time_stop ) {
- av_free_packet(&pkt);
-@@ -301,7 +294,7 @@ jboolean decodeAudio(JNIEnv * env, jobje
-
- /* close the output file */
- if (!(fmt->flags & AVFMT_NOFILE) && ofcx->pb != NULL) {
-- url_fclose(ofcx->pb);
-+ avio_close(ofcx->pb);
- }
-
- /* free the stream */
-@@ -309,7 +302,7 @@ jboolean decodeAudio(JNIEnv * env, jobje
- }
-
- if(codec_is_open >= 0) avcodec_close(ccx);
-- if(outbuf != NULL) free(outbuf);
-+ if(outbuf != NULL) av_free(outbuf);
- if(fcx != NULL) av_close_input_file(fcx);
-
- return ret;
-Index: Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeframe.c
-===================================================================
---- Jubler-4.6.1.orig/resources/ffmpeg/ffdecode/decodeframe.c
-+++ Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeframe.c
-@@ -122,7 +122,7 @@ AVPicture* decodeFrame(JNIEnv * env, job
- AVFrame *frame=avcodec_alloc_frame();
-
- /* Open the input file */
-- err = av_open_input_file(&fcx, input_filename, NULL, 0, NULL);
-+ err = avformat_open_input(&fcx, input_filename, NULL, NULL);
- if(err<0){
- DEBUG(env, this, "decodeFrame", "Could not open file '%s'.", input_filename);
- retflag = FALSE;
-@@ -157,7 +157,7 @@ AVPicture* decodeFrame(JNIEnv * env, job
- }
- else {
- // Open codec
-- if((codec_is_open = avcodec_open(ccx, codec)) < 0 ) {
-+ if((codec_is_open = avcodec_open2(ccx, codec, NULL)) < 0 ) {
- DEBUG(env, this, "decodeFrame", "Could not open codec.");
- retflag = FALSE;
- }
-@@ -190,7 +190,7 @@ AVPicture* decodeFrame(JNIEnv * env, job
- pack_duration = av_rescale_q(pkt.duration, fcx->streams[video_index]->time_base, AV_TIME_BASE_Q);
- comp_pts += pkt.duration;
- // Decode this packet
-- len = avcodec_decode_video(ccx, frame, &got_picture, pkt.data, pkt.size);
-+ len = avcodec_decode_video2(ccx, frame, &got_picture, &pkt);
- if (len < 0) {
- DEBUG(env, this, "decodeFrame", "Error while decoding.");
- retflag = FALSE;
-@@ -265,7 +265,7 @@ int file_info(JNIEnv * env, jobject this
- av_register_all();
-
- // Open the input file.
-- err = av_open_input_file(&fcx, input_filename, NULL, 0, NULL);
-+ err = avformat_open_input(&fcx, input_filename, NULL, NULL);
- if(err<0){
- DEBUG(env, this, "file_info", "Could not open file '%s'.", input_filename);
- return 1;
-@@ -275,9 +275,9 @@ int file_info(JNIEnv * env, jobject this
- err = av_find_stream_info(fcx);
-
- // Give us information about the file and exit
-- dump_format(fcx, 0, input_filename, FALSE);
-+ av_dump_format(fcx, 0, input_filename, FALSE);
-
-- av_close_input_file(fcx);
-+ avformat_close_input(&fcx);
- return 0;
- }
-
-Index: Jubler-4.6.1/resources/ffmpeg/ffdecode/grabinfo.c
-===================================================================
---- Jubler-4.6.1.orig/resources/ffmpeg/ffdecode/grabinfo.c
-+++ Jubler-4.6.1/resources/ffmpeg/ffdecode/grabinfo.c
-@@ -82,7 +82,7 @@ void get_information(JNIEnv * env, jobje
- av_register_all();
-
- // Open the input file.
-- err = av_open_input_file(&fcx, video_c, NULL, 0, NULL);
-+ err = avformat_open_input(&fcx, video_c, NULL, NULL);
- if(err<0) {
- DEBUG(env, this, "get_information", "Could not open file '%s'.", video_c);
- ret = JNI_FALSE;
-Index: Jubler-4.6.1/resources/ffmpeg/ffdecode/makecache.c
-===================================================================
---- Jubler-4.6.1.orig/resources/ffmpeg/ffdecode/makecache.c
-+++ Jubler-4.6.1/resources/ffmpeg/ffdecode/makecache.c
-@@ -59,7 +59,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- float ratewindow = 0;
- unsigned int offset=0, maxbyte=0, sampledcounter=1;
- FILE *cachefile=NULL;
-- uint8_t *outbuf=NULL;
-+ AVFrame *outbuf=NULL;
- jboolean nobrk = JNI_TRUE;
-
- int ENDIANESS = isLittleEndian();
-@@ -81,7 +81,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- ret = JNI_TRUE;
-
- // Open the input file.
-- err = av_open_input_file(&fcx, audio_c, NULL, 0, NULL);
-+ err = avformat_open_input(&fcx, audio_c, NULL, NULL);
- cachefile = fopen(cache_c, "wb");
- if(err<0){
- DEBUG(env, this, "makeCache", "Could not open audio file '%s'.", audio_c);
-@@ -91,7 +91,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- DEBUG(env, this, "makeCache", "Could not open cache file '%s'.", cache_c);
- ret = JNI_FALSE;
- }
-- outbuf = malloc(AVCODEC_MAX_AUDIO_FRAME_SIZE);
-+ outbuf = avcodec_alloc_frame();
- if(outbuf==NULL) {
- DEBUG(env, this, "makeCache", "Could not allocate memory for outbuf.");
- ret = JNI_FALSE;
-@@ -123,7 +123,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- }
- else {
- /* open it */
-- if ((codec_is_open = avcodec_open(ccx, codec)) < 0) {
-+ if ((codec_is_open = avcodec_open2(ccx, codec,NULL)) < 0) {
- DEBUG(env, this, "makeCache", "Could not open codec.");
- ret = JNI_FALSE;
- }
-@@ -175,7 +175,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- pack_pts = av_rescale_q(pkt.pts, fcx->streams[audio_index]->time_base, AV_TIME_BASE_Q);
- // Decode the paket
- got_audio = AVCODEC_MAX_AUDIO_FRAME_SIZE;
-- len = avcodec_decode_audio2(ccx, (short *)outbuf, &got_audio, pkt.data, pkt.size);
-+ len = avcodec_decode_audio4(ccx, outbuf, &got_audio, &pkt);
-
- if (len < 0) {
- DEBUG(env, this, "makeCache", "Error while decoding.");
-@@ -196,7 +196,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- if (bytecounter+offset + step*channels >= maxbyte) {
- for (j = 1; j <= channels ; j++) {
- // actually sample is not the whole sample, but the data for one channel each time
-- sample = (char)outbuf[bytecounter+ENDIANESS];
-+ sample = (char)outbuf->data[0][bytecounter+ENDIANESS];
- // min max averaging: only keep the highest and the lowest sample value
- if (maxsample[j-1] < sample) maxsample[j-1] = sample;
- if (minsample[j-1] > sample) minsample[j-1] = sample;
-@@ -215,7 +215,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- }
- else {
- for (j = 1; j <= channels; j++) {
-- sample = (char)outbuf[bytecounter+ENDIANESS];
-+ sample = (char)outbuf->data[0][bytecounter+ENDIANESS];
- // min max averaging
- if (maxsample[j-1] < sample) maxsample[j-1] = sample;
- if (minsample[j-1] > sample) minsample[j-1] = sample;
-@@ -254,7 +254,7 @@ JNIEXPORT jboolean JNICALL Java_com_pana
- if(minsample != NULL) free(minsample);
- if(cachefile != NULL) fclose(cachefile);
- if(codec_is_open >= 0) avcodec_close(ccx);
-- if(outbuf != NULL) free(outbuf);
-+ if(outbuf != NULL) av_free(outbuf);
- if(fcx != NULL) av_close_input_file(fcx);
-
- return ret;
diff --git a/media-video/jubler/files/jubler-4.6.1-ffmpeg-2.patch b/media-video/jubler/files/jubler-4.6.1-ffmpeg-2.patch
deleted file mode 100644
index 28f50b57d6ad..000000000000
--- a/media-video/jubler/files/jubler-4.6.1-ffmpeg-2.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeaudio.c b/Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeaudio.c
-index 92bf071..d163010 100644
---- a/Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeaudio.c
-+++ b/Jubler-4.6.1/resources/ffmpeg/ffdecode/decodeaudio.c
-@@ -37,6 +37,13 @@ jboolean decodeAudio(JNIEnv* env, jobject this, const char *input_filename, cons
- AVStream *add_audio_stream(JNIEnv* env, jobject this, AVFormatContext *oc, int codec_id, int sample_rate, int channels);
- void audio_enc_out(JNIEnv * env, jobject this, AVFormatContext *ofcx, AVStream *audio_st, const short *samples, int buf_size);
-
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+#ifndef MAX_AUDIO_FRAME_SIZE
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
-+#else
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE MAX_AUDIO_FRAME_SIZE
-+#endif
-+#endif
-
- JNIEXPORT jboolean JNICALL Java_com_panayotis_jubler_media_preview_decoders_FFMPEG_createClip(JNIEnv * env, jobject this, jstring audio, jstring wav, jlong start, jlong stop) {
- const char * audio_c;
-diff --git a/Jubler-4.6.1/resources/ffmpeg/ffdecode/makecache.c b/Jubler-4.6.1/resources/ffmpeg/ffdecode/makecache.c
-index d7ea88b..0190b79 100644
---- a/Jubler-4.6.1/resources/ffmpeg/ffdecode/makecache.c
-+++ b/Jubler-4.6.1/resources/ffmpeg/ffdecode/makecache.c
-@@ -38,6 +38,14 @@
- #include "defaults.h"
- #include "utilities.h"
-
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+#ifndef MAX_AUDIO_FRAME_SIZE
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
-+#else
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE MAX_AUDIO_FRAME_SIZE
-+#endif
-+#endif
-+
- JNIEXPORT jboolean JNICALL Java_com_panayotis_jubler_media_preview_decoders_NativeDecoder_makeCache(JNIEnv * env, jobject this, jstring audio, jstring cache, jstring original) {
- const char *audio_c;
- const char *cache_c;
diff --git a/media-video/jubler/files/jubler-4.6.1-gentoo.patch b/media-video/jubler/files/jubler-4.6.1-gentoo.patch
deleted file mode 100644
index 25afdba2fcc9..000000000000
--- a/media-video/jubler/files/jubler-4.6.1-gentoo.patch
+++ /dev/null
@@ -1,163 +0,0 @@
-diff -Nur Jubler-4.6.1/build.xml Jubler-4.6.1_patched/build.xml
---- Jubler-4.6.1/build.xml 2011-02-05 23:46:03.000000000 +0200
-+++ Jubler-4.6.1_patched/build.xml 2011-02-13 14:46:56.562977001 +0200
-@@ -1,36 +1,9 @@
- <?xml version="1.0" encoding="UTF-8"?>
--<project name="Jubler" default="dist" basedir=".">
-+<project name="Jubler" default="allparts" basedir=".">
- <description>Builds, tests, and runs the project Jubler.</description>
- <property file="core/src/com/panayotis/jubler/information/version.prop" />
--
-- <taskdef resource="net/sf/antcontrib/antlib.xml">
-- <classpath>
-- <pathelement location="resources/libs/ant-contrib/ant-contrib-1.0b3.jar"/>
-- </classpath>
-- </taskdef>
-+ <taskdef resource="net/sf/antcontrib/antlib.xml"/>
-
-- <taskdef name="jarbundler"
-- onerror="report"
-- classpath="/opt/local/share/java/jarbundler.jar"
-- classname="net.sourceforge.jarbundler.JarBundler" />
--
-- <taskdef name="izpack"
-- onerror="report"
-- classpath="../../Tools/IzPack/standalone-compiler.jar"
-- classname="com.izforge.izpack.ant.IzPackTask"/>
--
-- <taskdef name="launch4j"
-- onerror="report"
-- classpath="/opt/local/share/launch4j/launch4j.jar:/opt/local/share/launch4j/lib/xstream.jar"
-- classname="net.sf.launch4j.ant.Launch4jTask"/>
--
-- <target name="jupidator">
-- <ant antfile="../jupidator/build.xml" inheritall="false" target="jar"/>
-- <copy file="../jupidator/dist/jupidator.jar" todir="dist/lib"/>
-- <ant antfile="../jupidator/build.xml" inheritall="false" target="clean"/>
-- </target>
--
--
- <target name="i18n">
- <exec dir="resources/i18n" executable="bash" failonerror="true">
- <arg line="compile"/>
-@@ -45,12 +18,14 @@
- <move file="resources/help/jubler-faq.html" todir="dist/help"/>
- <copy file="resources/help/question.png" todir="dist/help"/>
- </target>
--
-+
-+ <target name="jupidator"/>
-+
- <target name="changelog" depends="jupidator">
- <delete file="ChangeLog.html"/>
- <echo message="" file="ChangeLog.html"/>
-- <java fork="true" classname="com.panayotis.jupidator.helpers.ChangeLogCreator" classpath="dist/lib/jupidator.jar">
-- <arg value="http://www.jubler.org/files/updates/update.xml"/>
-+ <java fork="true" classname="com.panayotis.jupidator.helpers.ChangeLogCreator" classpath="resources/libs/jupidator.jar">
-+ <arg value="update-${version}.xml"/>
- <arg value="ChangeLog.html"/>
- </java>
- </target>
-@@ -311,7 +286,7 @@
- </target>
-
- <!-- Create an isntallation-like file tree -->
-- <target name="-linuxinstall" depends="-linuxproperties, -cleandestdir, -linuxdesktopintegration">
-+ <target name="-linuxinstall" depends="-linuxproperties, -cleandestdir, linuxdesktopintegration">
- <!-- Basic Jubler files -->
- <copy file="dist/Jubler.jar" todir="${libdir}"/>
- <copy todir="${libdir}/lib">
-@@ -337,7 +312,7 @@
- </target>
-
- <!-- Linux desktop intergration -->
-- <target name="-linuxdesktopintegration" depends="-linuxproperties">
-+ <target name="linuxdesktopintegration" depends="-linuxproperties">
- <!-- Icon files -->
- <copy file="resources/installers/linux/jubler.menu" tofile="${sharedir}/menu/jubler"/>
- <copy file="resources/installers/linux/jubler.xpm" todir="${sharedir}/pixmaps"/>
-diff -Nur Jubler-4.6.1/core/src/com/panayotis/jubler/information/HelpBrowser.java Jubler-4.6.1_patched/core/src/com/panayotis/jubler/information/HelpBrowser.java
---- Jubler-4.6.1/core/src/com/panayotis/jubler/information/HelpBrowser.java 2011-01-31 01:19:02.000000000 +0200
-+++ Jubler-4.6.1_patched/core/src/com/panayotis/jubler/information/HelpBrowser.java 2011-02-12 14:38:50.220780001 +0200
-@@ -47,7 +47,7 @@
-
- history = new ArrayList<String>();
-
-- String initpage = "file:" + SystemFileFinder.getJublerAppPath() + "/help/jubler-faq.html";
-+ String initpage = "file:" + SystemFileFinder.getJublerAppPath() + "/../help/jubler-faq.html";
- setPage(initpage);
- history.add(initpage);
-
-diff -Nur Jubler-4.6.1/core/src/com/panayotis/jubler/os/SystemDependent.java Jubler-4.6.1_patched/core/src/com/panayotis/jubler/os/SystemDependent.java
---- Jubler-4.6.1/core/src/com/panayotis/jubler/os/SystemDependent.java 2011-01-31 01:19:02.000000000 +0200
-+++ Jubler-4.6.1_patched/core/src/com/panayotis/jubler/os/SystemDependent.java 2011-02-12 14:43:25.740780001 +0200
-@@ -182,7 +182,7 @@
- Runtime.getRuntime().exec("rundll32 url.dll,FileProtocolHandler " + url);
- else { //assume Unix or Linux
- String[] browsers = {
-- "firefox", "konqueror", "opera", "epiphany", "mozilla", "netscape"};
-+ "xdg-open", "firefox", "konqueror", "opera", "epiphany", "mozilla", "netscape"};
- String browser = null;
- for (int count = 0; count < browsers.length && browser == null; count++)
- if (Runtime.getRuntime().exec(
-diff -Nur Jubler-4.6.1/core/src/com/panayotis/jubler/os/SystemFileFinder.java Jubler-4.6.1_patched/core/src/com/panayotis/jubler/os/SystemFileFinder.java
---- Jubler-4.6.1/core/src/com/panayotis/jubler/os/SystemFileFinder.java 2011-02-05 01:59:45.000000000 +0200
-+++ Jubler-4.6.1_patched/core/src/com/panayotis/jubler/os/SystemFileFinder.java 2011-02-12 14:38:18.520780001 +0200
-@@ -56,9 +56,8 @@
-
- public static boolean loadLibrary(String name) {
- File libfile = findFile("lib" + FileCommunicator.FS + System.mapLibraryName(name));
-- if (libfile != null)
- try {
-- System.load(libfile.getAbsolutePath());
-+ System.loadLibrary(name);
- return true;
- } catch (UnsatisfiedLinkError e) {
- DEBUG.debug(e);
-diff -Nur Jubler-4.6.1/resources/ffmpeg/ffdecode/Makefile Jubler-4.6.1_patched/resources/ffmpeg/ffdecode/Makefile
---- Jubler-4.6.1/resources/ffmpeg/ffdecode/Makefile 2011-01-31 16:26:26.000000000 +0200
-+++ Jubler-4.6.1_patched/resources/ffmpeg/ffdecode/Makefile 2011-02-15 20:26:34.213149001 +0200
-@@ -12,9 +12,6 @@
- # Name of the produced library
- PROJ=ffdecode
-
--# Paths of include files
--JAVA_HOME=${shell /bin/sh ../../system/findjava.sh -j}
--
- # Current Path
- CPATH=${shell pwd}
-
-@@ -42,7 +39,6 @@
- # Various options
- FFCONF=configure
- LIBSUF=_${SYSTEM}.${ARCH}
--MAKEOPTS=-j3
-
- # Find requested files
- NATIVES=${shell cd ../../src && grep -r ' native ' * | grep -v '/.svn/' | gawk -F ':' '{print $$1}' | uniq | sed -e 's/\.java$$//g' | tr '/' '.' }
-@@ -136,7 +132,6 @@
- CCPREF_NOS=${shell echo ${CCPREF} | sed -e 's/-$$//g' }
- DCONFIG=--with-mp4v2 --host=${CCPREF_NOS}
-
--CC=${CCPREF}gcc
- RANLIB=${CCPREF}ranlib
-
- ifeq (${NOSTRIP},)
-@@ -151,7 +146,7 @@
- .SUFFIXES:.o .c
-
- .c.o:
-- ${CC} ${CFLAGS} ${GCCOPTS} -std=c99 -pedantic -O3 -Wall ${INCS} ${JINCLUDE} -c -o $@ $?
-+ ${CC} ${CFLAGS} ${GCCOPTS} -std=c99 -pedantic -Wall ${INCS} ${JINCLUDE} -c -o $@ $?
-
-
- develop:javacheck
-@@ -208,7 +203,7 @@
- LIB:${LIBNAME}
-
- ${LIBNAME}:${LIBRARYREQ} ${OBJS} ${RANLIBREQ}
-- ${LD} ${GCCOPTS} -o ${LIBNAME} ${OBJS} ${LIBS}
-+ ${LD} ${LDFLAGS} ${GCCOPTS} -o ${LIBNAME} ${OBJS} ${LIBS}
- ${STRIPCMD} ${LIBNAME}
-
-