summaryrefslogtreecommitdiff
path: root/media-video/ccextractor/ccextractor-0.85-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ccextractor/ccextractor-0.85-r2.ebuild')
-rw-r--r--media-video/ccextractor/ccextractor-0.85-r2.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/media-video/ccextractor/ccextractor-0.85-r2.ebuild b/media-video/ccextractor/ccextractor-0.85-r2.ebuild
index b7f0cdfe8825..982bba8df303 100644
--- a/media-video/ccextractor/ccextractor-0.85-r2.ebuild
+++ b/media-video/ccextractor/ccextractor-0.85-r2.ebuild
@@ -1,32 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils toolchain-funcs
+inherit cmake
DESCRIPTION="Extract closed captioning subtitles from video to SRT"
HOMEPAGE="https://www.ccextractor.org/"
SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
+S="${WORKDIR}/${PN}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+BDEPEND="app-arch/unzip
+ virtual/pkgconfig"
RDEPEND="
media-libs/libpng:0=
- sys-libs/zlib:=
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}/src"
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${PN}-0.85-fno-common.patch"
+)
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc ../docs/*.TXT
}