summaryrefslogtreecommitdiff
path: root/media-tv/tvheadend/tvheadend-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/tvheadend/tvheadend-9999.ebuild')
-rw-r--r--media-tv/tvheadend/tvheadend-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-tv/tvheadend/tvheadend-9999.ebuild b/media-tv/tvheadend/tvheadend-9999.ebuild
index 55773cf0ac91..04ecda4fb1b5 100644
--- a/media-tv/tvheadend/tvheadend-9999.ebuild
+++ b/media-tv/tvheadend/tvheadend-9999.ebuild
@@ -13,13 +13,12 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="+capmt +constcw +cwc dbus debug dvbcsa dvben50221 +dvb +ffmpeg hdhomerun +imagecache +inotify iptv libressl opus satip systemd +timeshift uriparser vpx x264 x265 xmltv zeroconf zlib"
+IUSE="+capmt +constcw +cwc dbus debug +ddci dvbcsa +dvb +ffmpeg hdhomerun +imagecache +inotify iptv libressl opus satip systemd +timeshift uriparser vpx x264 x265 xmltv zeroconf zlib"
RDEPEND="
virtual/libiconv
dbus? ( sys-apps/dbus )
dvbcsa? ( media-libs/libdvbcsa )
- dvben50221? ( media-tv/linuxtv-dvb-apps )
ffmpeg? ( media-video/ffmpeg:0/55.57.57[opus?,vpx?,x264?,x265?] )
hdhomerun? ( media-libs/libhdhomerun )
!libressl? ( dev-libs/openssl:= )
@@ -47,7 +46,10 @@ RDEPEND+="
dvb? ( media-tv/dtv-scan-tables )
xmltv? ( media-tv/xmltv )"
-REQUIRED_USE="dvbcsa? ( || ( capmt constcw cwc dvben50221 ) )"
+REQUIRED_USE="
+ dvbcsa? ( || ( capmt constcw cwc ) )
+ ddci? ( dvb )
+"
# Some patches from:
# https://github.com/rpmfusion/tvheadend
@@ -92,9 +94,9 @@ src_configure() {
$(use_enable cwc) \
$(use_enable dbus dbus_1) \
$(use_enable debug trace) \
+ $(use_enable ddci) \
$(use_enable dvb linuxdvb) \
$(use_enable dvbcsa) \
- $(use_enable dvben50221) \
$(use_enable ffmpeg libav) \
$(use_enable hdhomerun hdhomerun_client) \
$(use_enable imagecache) \