summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin57082 -> 57086 bytes
-rw-r--r--media-sound/alsaplayer/Manifest3
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild (renamed from media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild)31
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild37
4 files changed, 50 insertions, 21 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index 52d7c4f7f1fe..6b2a927c6a1a 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/alsaplayer/Manifest b/media-sound/alsaplayer/Manifest
index cd3f2cc9f0c5..695589ba6d27 100644
--- a/media-sound/alsaplayer/Manifest
+++ b/media-sound/alsaplayer/Manifest
@@ -1,3 +1,4 @@
DIST alsaplayer-0.99.81.tar.bz2 806906 BLAKE2B 6b37aaa65f6426a43483c3fa7e077ca89ce553655587e0f44ac61ade5d4f5467a304e18ef0142336b0cc94311498ccaa16d9ed2d6eb8109474626c6d1a4ca97d SHA512 6723b36837d01f14645bb1d43ec7c54c85e8afed9b020f56dc81b4de64b74e4da2504507fe83954c7b26817e90510c585d09e759fc11e731d4d27e86f3932650
-EBUILD alsaplayer-0.99.81-r2.ebuild 2019 BLAKE2B e3f5efd733fab5ee7d6078e176f506912b868f3a9d10675a3c003056e4ccee92381816536ef3e456f5bd11c701bbd467eaff91cc5925ce799b7a04b8efeeca8f SHA512 c6b2869f0366f409674cda5a68d59b4d112f3845522a60896131ad85fa9a2db3e7d0409009c92837be8d6edc1464b67842096bfb837d711766c7684d86257c79
+EBUILD alsaplayer-0.99.81-r3.ebuild 1859 BLAKE2B e48439e1b06b72f6022e2db06c504ea0a671b9aebb4d555a272eaa904b61ca76e8c8ac38c15d72ad023e2c30c19c6501bd29cc9615a0c8f882fd0ff2dede03a3 SHA512 bedfe341424bcda1eb6673331886b94dea3cd3df086d9865af02b772025f245c8ac2813fa84ef58e1aa4a033411b110238fe7985551c53d8fef180b22afc765e
+EBUILD files/alsaplayer-0.99.81-autotools.ebuild 943 BLAKE2B 0f51ca345e6ccadd25f28ae1961af3ea70055297ad020aa232b9604ffb80c68de79ce42b231a3f8e3bf66ba0c92cd9759b604eab3aae09c9e7b61ab96b0da047 SHA512 a0c55913e8f52578f441229ed3cab999416732b45dc5019965fc32635cb5b9f7fb603ef23eacc5b22da9d423d751a12a448f1f9293e929a303673d28a33d0ae5
MISC metadata.xml 338 BLAKE2B 10b361f79fc3faabd4f58308beb752d40d950e963b754519fb78503c0b7bb36492473b4c5ead9624e6e82d1c47d658237eab69a38dce4647cffd73c8738e21cd SHA512 af01ff0b9d7267d8a730ad734d51c6339dfa81eb4d0a2b41eb85d5f52a8fb10db872f1ea2df4b6450b0a89020884470daa28bfd1288aaeff6671c88b7972626e
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild
index 098fdbbe3336..70ee1adcfa99 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools desktop xdg
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ~ppc ~riscv ~sparc x86"
IUSE="+alsa audiofile doc flac gtk id3tag jack mad mikmod nas nls ogg opengl oss vorbis xosd"
+REQUIRED_USE="|| ( alsa jack nas oss )"
RDEPEND="
media-libs/libsndfile:=
@@ -31,27 +32,17 @@ RDEPEND="
vorbis? ( media-libs/libvorbis )
xosd? ( x11-libs/xosd )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )
oss? ( virtual/os-headers )"
-REQUIRED_USE="|| ( alsa jack nas oss )"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.ebuild )
src_prepare() {
default
-
- sed -i \
- -e 's:AM_CFLAGS = $(AM_CXXFLAGS)::' \
- output/jack/Makefile.am || die
-
- sed -i \
- -e 's:-O2 -funroll-loops -finline-functions -ffast-math::' \
- configure.ac || die
-
- sed -i \
- -e "s:/usr/lib:/usr/$(get_libdir):" \
- configure.ac config.rpath || die
-
+ cp "${BROOT}"/usr/share/gettext/config.rpath . || die
eautoreconf
}
@@ -83,5 +74,5 @@ src_install() {
newicon interface/gtk2/pixmaps/logo.xpm ${PN}.xpm
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild
new file mode 100644
index 000000000000..b51277317e0f
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild
@@ -0,0 +1,37 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -82,11 +82,6 @@
+ dnl PKGCONFIG preparations
+ dnl ======================
+
+-if test -z $PKG_CONFIG_PATH; then
+- PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
+-fi
+-
+-export PKG_CONFIG_PATH
+
+
+ dnl ===============
+@@ -639,10 +634,10 @@
+
+ AC_MSG_CHECKING(for gcc optimization flags)
+ old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"
++CFLAGS="$CFLAGS -Wall"
+ AC_TRY_COMPILE([#include <stdio.h>],
+ [ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
++[ EXTRA_OPT_CFLAGS="$CFLAGS -Wall"],[ EXTRA_OPT_CFLAGS=""])
+ CFLAGS=$old_cflags
+ AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+
+--- a/output/jack/Makefile.am
++++ b/output/jack/Makefile.am
+@@ -24,7 +24,6 @@
+
+ AM_CXXFLAGS = $(COMMON_FLAGS) $(JACK_CFLAGS)
+
+-AM_CFLAGS = $(AM_CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/output
+