summaryrefslogtreecommitdiff
path: root/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild')
-rw-r--r--media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild b/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
index 12fa7d074dc4..93e6b7087cd3 100644
--- a/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
+++ b/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
USE_RUBY="ruby24 ruby25 ruby26"
inherit eutils multiprocessing perl-functions python-single-r1 ruby-single toolchain-funcs
@@ -308,8 +308,11 @@ src_install() {
# to avoid code changed let's just un-gzip manpages
local m
for m in "${ED}"/usr/share/man/man1/*.gz; do
- einfo "Uncompressing '${m#${ED}}' back."
- gzip -d "${m}" || die
+ # For some combination of USEs no mans are installed.
+ if [[ -f $m ]]; then
+ einfo "Uncompressing '${m#${ED}}' back."
+ gzip -d "${m}" || die
+ fi
done
}