summaryrefslogtreecommitdiff
path: root/media-sound/tomahawk
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/tomahawk')
-rw-r--r--media-sound/tomahawk/Manifest3
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch240
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild2
3 files changed, 244 insertions, 1 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
index 1e2950ca81e9..dda0e0928b32 100644
--- a/media-sound/tomahawk/Manifest
+++ b/media-sound/tomahawk/Manifest
@@ -1,4 +1,5 @@
+AUX tomahawk-0.9.0_pre20170808-qt-5.11b3.patch 9408 BLAKE2B 94acf68fc8bed9c5f7aeffe08a528803bf8aee2742a45e15361004b33c5506788f1e057bca23bccfb32ddbbeae0f67e3eb23213547b59c6d9c1c6fb65f91c04b SHA512 2a7d457e843c4e85b69c7bffceda1f13b63b510719a1169f7d35ea810810e718ae34a05eaef5284daaeb60a45635d138da43e757f9f581b9797b8ec900f06dbe
AUX tomahawk-liblastfm-cmake.patch 3722 BLAKE2B ec639c4e2d36ddb9a087d37265b453a8085a869d950d2b8261906ebdef5f13ba3794f0417e00be422a5f0f1ef6cbe9e15f371c924be6f55cd291bb0257dcae09 SHA512 3e65d70d274abeee63cf98f1ee390157a95d82884678251f77b3257e3f7f042a778c6f346b47b3c5c5a0cfff9ac12e4d05d6bf5de818f0c1f1d433f8cce00e53
DIST tomahawk-0.9.0_pre20170808.tar.gz 9913232 BLAKE2B 5a7ebd9419fece090c0aec1f8f47bf35e1f0fbae5cd6a41803ac265e7310dadac61ba4f2e25b0d2fbbb0068cbb3f7098c1d330ac81e671be1028ed3b78d32560 SHA512 edaa4c1637ca460f838dfdd7ecc9d5dae0b66a8280deb8dc6140c673ecc76aa1055efbbac1e9b2937ec01d6dd657935b907cadceb2059f8e055305e872866c2b
-EBUILD tomahawk-0.9.0_pre20170808.ebuild 1774 BLAKE2B 6c6d9fa41e75440f2f79caf7e087057276b081bb64e578889a3ebfdf250ba11800667e42e5e36f6f47a9847f1c4ebf7bdf797572e222fe6a712db0af531e787c SHA512 2807ec3073deec75bb477334f11408291d846651e3e7596fc41ae39ef847776833b13eb5335e3c9907c664a1ad5581cdf68b0dfe8c42795257e549de695a074a
+EBUILD tomahawk-0.9.0_pre20170808.ebuild 1822 BLAKE2B c1ad229474e85cef7db31354c1db25b2e83a5fa3014f4c6a37342606fe57f627a5b84c68a6a455f0b6079c787f69a9d4cd2bdcf94f2fc69dda88cfa94701d54b SHA512 51dfb34fe84dcb5cf4bdca4325b8d24f73739c4a0b062693a30cc5235e185e8c0e10040d83b0e3bde88772448d1d7714a889b8a864f5271975d5fd325b7a81c1
MISC metadata.xml 554 BLAKE2B 162f2f8391a4b5226910cae53834752b14eb003091e7cce4f345f93923a6a09ada4289008efb9e76886f1b7dbd7709f75e010abfb85af71745e06b11394fb9a3 SHA512 25fb52f0a1c11c21f841e68d1485c4e1bcb8194ef16b414f71caa7d378fcea31461f73b0bd064049435d09baf4c90ebb85113f248232c5a933b54f7c971ef017
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch
new file mode 100644
index 000000000000..6fb139c6bf16
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20170808-qt-5.11b3.patch
@@ -0,0 +1,240 @@
+From 208a259b08676f2e0db35451b78e8225cb87547d Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 17 Apr 2018 13:09:25 +0200
+Subject: [PATCH] Fix build with Qt 5.11_beta3 (dropping qt5_use_modules)
+
+---
+ CMakeLists.txt | 3 ---
+ TomahawkAddLibrary.cmake | 4 +++-
+ TomahawkUse.cmake.in | 3 ---
+ src/crashreporter/CMakeLists.txt | 6 ++++--
+ src/libtomahawk/CMakeLists.txt | 18 +++++++++++-------
+ src/tests/tomahawk_add_test.cmake | 8 ++++++--
+ src/tomahawk/CMakeLists.txt | 17 ++++++++++-------
+ src/tools/database-reader/CMakeLists.txt | 4 +++-
+ .../tomahawk-test-musicscan/CMakeLists.txt | 4 +++-
+ .../kdsingleapplicationguard/CMakeLists.txt | 4 +++-
+ .../src/certificate/CMakeLists.txt | 6 +++---
+ .../qxt/qxtweb-standalone/CMakeLists.txt | 10 +++++-----
+ 12 files changed, 51 insertions(+), 36 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7004e1b70..616db971f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -243,9 +243,6 @@ if( NOT Qt5Core_DIR )
+ macro_optional_find_package(Qt4 4.7.0 COMPONENTS ${NEEDED_QT4_COMPONENTS} )
+ macro_log_feature(QT4_FOUND "Qt" "A cross-platform application and UI framework" "http://qt-project.org" TRUE "" "If you see this, although libqt4-devel is installed, check whether the \n qtwebkit-devel package and whatever contains QtUiTools is installed too")
+
+- macro(qt5_use_modules)
+- endmacro()
+-
+ macro(qt_wrap_ui)
+ qt4_wrap_ui(${ARGN})
+ endmacro()
+diff --git a/TomahawkAddLibrary.cmake b/TomahawkAddLibrary.cmake
+index 384394e45..f67a48900 100644
+--- a/TomahawkAddLibrary.cmake
++++ b/TomahawkAddLibrary.cmake
+@@ -46,7 +46,9 @@ function(tomahawk_add_library)
+ endif()
+
+ # HACK: add qt modules - every lib should define its own set of modules
+- qt5_use_modules(${target} Core Network Widgets Sql Xml ${LIBRARY_QT5_MODULES})
++ if(Qt5Core_DIR)
++ target_link_libraries(${target} Qt5::Core Qt5::Network Qt5::Widgets Qt5::Sql Qt5::Xml)
++ endif()
+
+ # definitions - can this be moved into set_target_properties below?
+ add_definitions(${QT_DEFINITIONS})
+diff --git a/TomahawkUse.cmake.in b/TomahawkUse.cmake.in
+index cb39fe219..9401e1851 100644
+--- a/TomahawkUse.cmake.in
++++ b/TomahawkUse.cmake.in
+@@ -81,9 +81,6 @@ else(TOMAHAWK_QT5)
+ find_package(Qt4 4.7.0 COMPONENTS ${NEEDED_QT4_COMPONENTS})
+ include( ${QT_USE_FILE} )
+
+- macro(qt5_use_modules)
+- endmacro()
+-
+ macro(qt_wrap_ui)
+ qt4_wrap_ui(${ARGN})
+ endmacro()
+diff --git a/src/crashreporter/CMakeLists.txt b/src/crashreporter/CMakeLists.txt
+index b837eb941..d47c91b62 100644
+--- a/src/crashreporter/CMakeLists.txt
++++ b/src/crashreporter/CMakeLists.txt
+@@ -43,7 +43,9 @@ target_link_libraries( ${TOMAHAWK_CRASH_REPORTER_TARGET}
+ ${QT_LIBRARIES}
+ )
+
++if(Qt5Core_DIR)
++ target_link_libraries(${TOMAHAWK_CRASH_REPORTER_TARGET} Qt5::Widgets Qt5::Network)
++endif()
++
+ set_target_properties(${TOMAHAWK_CRASH_REPORTER_TARGET} PROPERTIES AUTOMOC ON)
+ install(TARGETS ${TOMAHAWK_CRASH_REPORTER_TARGET} RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR})
+-
+-qt5_use_modules(${TOMAHAWK_CRASH_REPORTER_TARGET} Widgets Network)
+diff --git a/src/libtomahawk/CMakeLists.txt b/src/libtomahawk/CMakeLists.txt
+index adb3edfa0..a85a835ad 100644
+--- a/src/libtomahawk/CMakeLists.txt
++++ b/src/libtomahawk/CMakeLists.txt
+@@ -500,12 +500,17 @@ set_target_properties(
+ OUTPUT_NAME ${TOMAHAWK_BASE_TARGET_NAME}
+ )
+
+-
+-qt5_use_modules(${TOMAHAWK_LIBRARY} Widgets Network Sql WebKitWidgets Concurrent Xml UiTools Svg)
+-IF(APPLE)
+- qt5_use_modules(${TOMAHAWK_LIBRARY} MacExtras)
+-ENDIF()
+-
++if(Qt5Core_DIR)
++ target_link_libraries(${TOMAHAWK_LIBRARY}
++ Qt5::Widgets Qt5::Network Qt5::Sql Qt5::WebKitWidgets Qt5::Concurrent Qt5::Xml Qt5::UiTools Qt5::Svg
++ )
++ if(APPLE)
++ target_link_libraries(${TOMAHAWK_LIBRARY} Qt5::MacExtras)
++ endif()
++ if( UNIX AND NOT APPLE )
++ target_link_libraries(${TOMAHAWK_LIBRARY} Qt5::DBus)
++ endif()
++endif()
+
+ IF(QCA2_FOUND)
+ INCLUDE_DIRECTORIES( ${QCA2_INCLUDE_DIR} )
+@@ -514,7 +519,6 @@ ENDIF(QCA2_FOUND)
+
+ IF( UNIX AND NOT APPLE )
+ LIST(APPEND LINK_LIBRARIES ${QT_QTDBUS_LIBRARIES} )
+- qt5_use_modules(${TOMAHAWK_LIBRARY} DBus)
+ ENDIF( UNIX AND NOT APPLE )
+
+ TARGET_LINK_LIBRARIES( ${TOMAHAWK_LIBRARY}
+diff --git a/src/tests/tomahawk_add_test.cmake b/src/tests/tomahawk_add_test.cmake
+index 464b8c918..e3e20ed4b 100644
+--- a/src/tests/tomahawk_add_test.cmake
++++ b/src/tests/tomahawk_add_test.cmake
+@@ -16,8 +16,12 @@ macro(tomahawk_add_test test_class)
+ ${QT_QTCORE_LIBRARY}
+ )
+
+- add_test(NAME ${TOMAHAWK_TEST_TARGET} COMMAND ${TOMAHAWK_TEST_TARGET})
++ if(Qt5Core_DIR)
++ target_link_libraries(${TOMAHAWK_TEST_TARGET}
++ Qt5::Core Qt5::Network Qt5::Widgets Qt5::Sql Qt5::Xml Qt5::Test
++ )
++ endif()
+
+- qt5_use_modules(${TOMAHAWK_TEST_TARGET} Core Network Widgets Sql Xml Test)
++ add_test(NAME ${TOMAHAWK_TEST_TARGET} COMMAND ${TOMAHAWK_TEST_TARGET})
+
+ endmacro()
+diff --git a/src/tomahawk/CMakeLists.txt b/src/tomahawk/CMakeLists.txt
+index cb60b8012..7facdc3da 100644
+--- a/src/tomahawk/CMakeLists.txt
++++ b/src/tomahawk/CMakeLists.txt
+@@ -171,13 +171,16 @@ SET_TARGET_PROPERTIES( ${TOMAHAWK_APPLICATION_TARGET}
+ RUNTIME_OUTPUT_NAME ${TOMAHAWK_RUNTIME_OUTPUT_NAME}
+ )
+
+-
+-qt5_use_modules(${TOMAHAWK_APPLICATION_TARGET} Core Widgets Network Sql WebKitWidgets)
+-if(APPLE)
+- qt5_use_modules(${TOMAHAWK_APPLICATION_TARGET} MacExtras)
+-endif()
+-if(WIN32)
+- qt5_use_modules(${TOMAHAWK_APPLICATION_TARGET} WinExtras)
++if(Qt5Core_DIR)
++ target_link_libraries(${TOMAHAWK_APPLICATION_TARGET}
++ Qt5::Core Qt5::Widgets Qt5::Network Qt5::Sql Qt5::WebKitWidgets
++ )
++ if(APPLE)
++ target_link_libraries(${TOMAHAWK_APPLICATION_TARGET} Qt5::MacExtras)
++ endif()
++ if(WIN32)
++ target_link_libraries(${TOMAHAWK_APPLICATION_TARGET} Qt5::WinExtras)
++ endif()
+ endif()
+
+ MESSAGE( STATUS "OS_SPECIFIC_LINK_LIBRARIES: ${OS_SPECIFIC_LINK_LIBRARIES}" )
+diff --git a/src/tools/database-reader/CMakeLists.txt b/src/tools/database-reader/CMakeLists.txt
+index 72bb1e0db..d7a45f0a6 100644
+--- a/src/tools/database-reader/CMakeLists.txt
++++ b/src/tools/database-reader/CMakeLists.txt
+@@ -15,7 +15,9 @@ set_target_properties( ${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET}
+ target_link_libraries( ${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET}
+ ${TOMAHAWK_LIBRARIES}
+ )
++if(Qt5Core_DIR)
++ target_link_libraries(${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET} Qt5::Core)
++endif()
+
+-qt5_use_modules(${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET} Core)
+ install( TARGETS ${TOMAHAWK_TOOL_DB_LIST_ARTISTS_TARGET} BUNDLE DESTINATION . RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} )
+
+diff --git a/src/tools/tomahawk-test-musicscan/CMakeLists.txt b/src/tools/tomahawk-test-musicscan/CMakeLists.txt
+index 097e3fc08..15c0c479f 100644
+--- a/src/tools/tomahawk-test-musicscan/CMakeLists.txt
++++ b/src/tools/tomahawk-test-musicscan/CMakeLists.txt
+@@ -14,6 +14,8 @@ set_target_properties( ${TOMAHAWK_TOOL_MUSICSCAN_TARGET}
+ target_link_libraries( ${TOMAHAWK_TOOL_MUSICSCAN_TARGET}
+ ${TOMAHAWK_LIBRARIES}
+ )
++if(Qt5Core_DIR)
++ target_link_libraries(${TOMAHAWK_TOOL_MUSICSCAN_TARGET} Qt5::Core Qt5::Gui Qt5::Network Qt5::Widgets)
++endif()
+
+-qt5_use_modules(${TOMAHAWK_TOOL_MUSICSCAN_TARGET} Core Gui Network Widgets)
+ install( TARGETS ${TOMAHAWK_TOOL_MUSICSCAN_TARGET} BUNDLE DESTINATION . RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} )
+diff --git a/thirdparty/kdsingleapplicationguard/CMakeLists.txt b/thirdparty/kdsingleapplicationguard/CMakeLists.txt
+index af4cf8704..9d6b49014 100644
+--- a/thirdparty/kdsingleapplicationguard/CMakeLists.txt
++++ b/thirdparty/kdsingleapplicationguard/CMakeLists.txt
+@@ -24,4 +24,6 @@ set_target_properties(
+ PROPERTIES
+ AUTOMOC TRUE
+ )
+-qt5_use_modules(kdsingleapplicationguard Core)
++if(Qt5Core_DIR)
++ target_link_libraries(kdsingleapplicationguard Qt5::Core)
++endif()
+diff --git a/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt b/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt
+index a51157cf7..bfb0b0afe 100644
+--- a/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt
++++ b/thirdparty/qt-certificate-addon/src/certificate/CMakeLists.txt
+@@ -25,6 +25,6 @@ set_target_properties(
+ PROPERTIES
+ AUTOMOC TRUE
+ )
+-qt5_use_modules(qtcertificateaddon Core Network)
+-
+-
++if(Qt5Core_DIR)
++ target_link_libraries(qtcertificateaddon Qt5::Core Qt5::Network)
++endif()
+diff --git a/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt b/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt
+index 654a6aab5..1babe0cfc 100644
+--- a/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt
++++ b/thirdparty/qxt/qxtweb-standalone/CMakeLists.txt
+@@ -74,10 +74,10 @@ ADD_LIBRARY( qxtweb-standalone STATIC
+ )
+
+
+-target_link_libraries( qxtweb-standalone
+- ${QT_LIBRARIES}
+-)
+-
+-qt5_use_modules( qxtweb-standalone Network )
++if(Qt5Core_DIR)
++ target_link_libraries( qxtweb-standalone Qt5::Network)
++else()
++ target_link_libraries( qxtweb-standalone ${QT_LIBRARIES} )
++endif()
+
+ set_target_properties( qxtweb-standalone PROPERTIES AUTOMOC TRUE )
+--
+2.17.0
+
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
index 15c73708429e..8cb2950b9aa9 100644
--- a/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
+++ b/media-sound/tomahawk/tomahawk-0.9.0_pre20170808.ebuild
@@ -50,6 +50,8 @@ RDEPEND="${CDEPEND}
app-crypt/qca:2[ssl]
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11b3.patch" )
+
src_prepare() {
kde5_src_prepare
has_version "media-libs/liblastfm[qt5]" &&