summaryrefslogtreecommitdiff
path: root/media-sound/rcenter/rcenter-0.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/rcenter/rcenter-0.6.2.ebuild')
-rw-r--r--media-sound/rcenter/rcenter-0.6.2.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/media-sound/rcenter/rcenter-0.6.2.ebuild b/media-sound/rcenter/rcenter-0.6.2.ebuild
index d071eadc0d76..295c65fb14a2 100644
--- a/media-sound/rcenter/rcenter-0.6.2.ebuild
+++ b/media-sound/rcenter/rcenter-0.6.2.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
-
-IUSE=""
+inherit toolchain-funcs
DESCRIPTION="Rcenter - A program to control the EMU10K Remote Control"
HOMEPAGE="http://rooster.stanford.edu/~ben/projects/rcenter.php"
@@ -16,21 +14,22 @@ SLOT="0"
#-sparc: emu10k1 doesn't get recognized on sparc hardware
KEYWORDS="amd64 -sparc x86"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-makefile.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+src_configure() {
+ tc-export CC
}
src_install() {
- chmod 755 rcenter
dobin rcenter
- dodir /usr/share/rcenter
- cp -R config "${D}"/usr/share/rcenter/
+ fperms 755 /usr/bin/rcenter
+
+ insinto /usr/share/rcenter
+ doins -r config
+
dodoc HISTORY README
}
@@ -38,7 +37,7 @@ pkg_postinst() {
elog "Rcenter Installed - However You need to setup the scripts"
elog "for making remote control commands actually work"
elog
- elog "The Skel scripts can be copied from /usr/share/rcenter/config to <user>/.rcenter"
+ elog "The Skel scripts can be copied from ${EROOT}/usr/share/rcenter/config to <user>/.rcenter"
elog "Where <user> is a person who will use rcenter"
elog "Remeber to use emu-config -i to turn on the remote"
}