summaryrefslogtreecommitdiff
path: root/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch')
-rw-r--r--media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch b/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
new file mode 100644
index 000000000000..9ea401abc26e
--- /dev/null
+++ b/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 47ea36f..0194f32 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,6 +8,7 @@ project(qsynth
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+
+ set (CONFIG_VERSION ${PROJECT_VERSION})
++#[[
+ execute_process (
+ COMMAND git describe --tags --dirty --abbrev=6
+ OUTPUT_VARIABLE GIT_DESCRIBE_OUTPUT
+@@ -29,6 +30,8 @@ if (GIT_DESCRIBE_RESULT EQUAL 0)
+ else ()
+ set (VERSION "${PROJECT_VERSION}")
+ endif ()
++]]
++set (VERSION "${PROJECT_VERSION}")
+
+ set (PACKAGE_NAME "Qsynth")
+ set (PACKAGE_VERSION "${VERSION}")