summaryrefslogtreecommitdiff
path: root/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch')
-rw-r--r--media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch b/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch
new file mode 100644
index 000000000000..06c073aa2761
--- /dev/null
+++ b/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,10 +21,11 @@
+ PKG_CHECK_MODULES([GOBJECT], [gobject-2.0 >= 2.38])
+ PKG_CHECK_MODULES([GIO], [gio-unix-2.0])
+
+-AC_PATH_PROG([GDBUS_CODEGEN], [`$PKG_CONFIG --variable=gdbus_codegen gio-2.0`])
++GDBUS_CODEGEN=`$PKG_CONFIG --variable=gdbus_codegen gio-2.0`
+ if test -z "$GDBUS_CODEGEN"; then
+ AC_MSG_ERROR([*** gdbus-codegen is required to build playerctl])
+ fi
++AC_SUBST(GDBUS_CODEGEN)
+
+ # Checks for typedefs, structures, and compiler characteristics
+ AC_PROG_CC_STDC