summaryrefslogtreecommitdiff
path: root/media-sound/oggtst/oggtst-0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/oggtst/oggtst-0.0.ebuild')
-rw-r--r--media-sound/oggtst/oggtst-0.0.ebuild31
1 files changed, 13 insertions, 18 deletions
diff --git a/media-sound/oggtst/oggtst-0.0.ebuild b/media-sound/oggtst/oggtst-0.0.ebuild
index 0a24362b9b13..52a8223e6f76 100644
--- a/media-sound/oggtst/oggtst-0.0.ebuild
+++ b/media-sound/oggtst/oggtst-0.0.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit autotools
DESCRIPTION="A tool for calculating ogg-vorbis playing time"
HOMEPAGE="http://gnometoaster.rulez.org/"
-SRC_URI="http://gnometoaster.rulez.org/archive/${PN}.tgz"
+SRC_URI="mirror://gentoo/${PN}.tgz -> ${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE=""
-RDEPEND=">=media-libs/libao-0.8.0
- >=media-libs/libvorbis-1.0_rc2"
+RDEPEND="
+ media-libs/libao:=
+ media-libs/libvorbis:="
+DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # upstream didn't use make dist to create the tarball, there are
- # unbound symlinks inside it.
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ # upstream didn't use make dist to create the tarball,
+ # there are unbound symlinks inside it.
eautoreconf
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README
-}