summaryrefslogtreecommitdiff
path: root/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild')
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
index 467241065e7c..a03af0ddc1db 100644
--- a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit autotools
-MY_PV="${PV}-1" # Patchlevel
+MY_PV="${PV}-1" # Patchlevel
DESCRIPTION="A command line tool to clean and edit mp3 files"
HOMEPAGE="https://sourceforge.net/projects/mp3asm/"
@@ -18,11 +18,15 @@ KEYWORDS="amd64 ppc sparc x86"
# the author uses weird numbering...
S="${WORKDIR}/${PN}-0.1"
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+PATCHES=( "${FILESDIR}"/${P}-fix-autotools.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
- dobin src/mp3asm
- dodoc Changelog README
+ default
+ dodoc Changelog
}