summaryrefslogtreecommitdiff
path: root/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild')
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
index a03af0ddc1db..ea03c2c4e219 100644
--- a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -1,32 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
MY_PV="${PV}-1" # Patchlevel
-DESCRIPTION="A command line tool to clean and edit mp3 files"
+DESCRIPTION="Command line tool to clean and edit mp3 files"
HOMEPAGE="https://sourceforge.net/projects/mp3asm/"
SRC_URI="mirror://sourceforge/mp3asm/${PN}-${MY_PV}.tar.bz2"
+S="${WORKDIR}/${PN}-0.1" # the author uses weird numbering...
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-# the author uses weird numbering...
-S="${WORKDIR}/${PN}-0.1"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-autotools.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-autotools.patch
+ "${FILESDIR}"/${P}-log.patch
+)
src_prepare() {
default
- mv configure.{in,ac} || die
+
eautoreconf
}
src_install() {
default
+
dodoc Changelog
}