summaryrefslogtreecommitdiff
path: root/media-sound/marrie/marrie-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/marrie/marrie-9999.ebuild')
-rw-r--r--media-sound/marrie/marrie-9999.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/media-sound/marrie/marrie-9999.ebuild b/media-sound/marrie/marrie-9999.ebuild
index 5e26f9cf5c9b..a1e727f450c9 100644
--- a/media-sound/marrie/marrie-9999.ebuild
+++ b/media-sound/marrie/marrie-9999.ebuild
@@ -4,35 +4,26 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
-GIT_ECLASS=""
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
fi
-inherit distutils-r1 ${GIT_ECLASS}
-
DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
HOMEPAGE="https://github.com/rafaelmartins/marrie"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-
LICENSE="BSD"
SLOT="0"
-IUSE=""
RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
pkg_postinst() {
- distutils-r1_pkg_postinst
elog
elog "You'll need a media player and a file downloader."
elog "Recommended packages: net-misc/wget and media-video/mpv"