summaryrefslogtreecommitdiff
path: root/media-sound/lilypond/lilypond-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lilypond/lilypond-9999.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild23
1 files changed, 4 insertions, 19 deletions
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index eb38a121f497..fc14ef8ed34b 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
@@ -24,11 +24,7 @@ IUSE="debug emacs guile2 profile vim-syntax"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
BDEPEND="
- >=dev-texlive/texlive-metapost-2013
- || (
- >=app-text/texlive-core-2013
- >=dev-tex/metapost-1.803
- )
+ >=dev-texlive/texlive-metapost-2020
>=sys-apps/texinfo-4.11
>=sys-devel/bison-2.0
sys-devel/flex
@@ -61,19 +57,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.21.1-fix-font-size.patch
)
-DOCS=( DEDICATION HACKING README.txt ROADMAP )
-
-pkg_setup() {
- # make sure >=metapost-1.803 is selected if it's installed, bug 498704
- if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
- if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
- einfo "Updating metapost symlink"
- eselect mpost update || die
- fi
- fi
-
- python-single-r1_pkg_setup
-}
+DOCS=( DEDICATION HACKING Documentation/out/topdocs/README.txt ROADMAP )
src_prepare() {
default
@@ -105,6 +89,7 @@ src_configure() {
$(use_enable debug debugging)
$(use_enable profile profiling)
)
+ export VARTEXFONTS="${T}/fonts" # https://bugs.gentoo.org/692010
econf "${myeconfargs[@]}"
}