summaryrefslogtreecommitdiff
path: root/media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild')
-rw-r--r--media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild b/media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild
index de8b8d6c52df..e5b64d9f6255 100644
--- a/media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild
+++ b/media-sound/gogglesmm/gogglesmm-1.2.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake xdg
DESCRIPTION="Fast and light music player"
HOMEPAGE="https://gogglesmm.github.io"
@@ -34,6 +34,10 @@ DEPEND="dev-util/cmake ${RDEPEND}"
PATCHES=( "${FILESDIR}"/"${P}"-use-fox-1.7.67.patch )
+src_prepare() {
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_DBUS="$(usex dbus)"