summaryrefslogtreecommitdiff
path: root/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-3.1.1.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild b/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild
new file mode 100644
index 000000000000..bc65a3bed639
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ >=dev-python/python-ly-0.9.4[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}