summaryrefslogtreecommitdiff
path: root/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild')
-rw-r--r--media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild b/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
index e5316f528a5a..1113fa708d1e 100644
--- a/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
+++ b/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils java-pkg-2 java-ant-2
+inherit desktop java-pkg-2 java-ant-2
DESCRIPTION="Open-source audiofile tagger"
HOMEPAGE="http://entagged.sourceforge.net/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="|| ( GPL-2 LGPL-2.1 )"
+LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
@@ -17,23 +17,23 @@ IUSE=""
S="${WORKDIR}"
RDEPEND=">=virtual/jre-1.5
- dev-java/squareness-jlf
- dev-db/hsqldb"
+ dev-java/squareness-jlf:0
+ dev-db/hsqldb:0"
DEPEND=">=virtual/jdk-1.5
- dev-db/hsqldb"
+ dev-db/hsqldb:0"
EANT_BUILD_XML="entagged/build.xml"
EANT_BUILD_TARGET="build"
-src_unpack() {
- unpack ${A}
+src_prepare() {
+ java-pkg-2_src_prepare
mkdir -p test/entagged/junit || die
mv entagged/entagged/junit test/entagged || die
rm entagged/*.jar || die
java-pkg_jarfrom hsqldb hsqldb.jar entagged/hsqldb.jar
cd entagged || die
- epatch "${FILESDIR}"/${P}-buildfixes.patch
+ eapply "${FILESDIR}"/${P}-buildfixes.patch
}
src_install() {