summaryrefslogtreecommitdiff
path: root/media-sound/drumstick/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/drumstick/files')
-rw-r--r--media-sound/drumstick/files/0.5.0-doc_automagicness.patch20
-rw-r--r--media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch26
-rw-r--r--media-sound/drumstick/files/0.5.0-underlinking.patch17
-rw-r--r--media-sound/drumstick/files/drumstick-1.0.2-gcc6.patch35
4 files changed, 0 insertions, 98 deletions
diff --git a/media-sound/drumstick/files/0.5.0-doc_automagicness.patch b/media-sound/drumstick/files/0.5.0-doc_automagicness.patch
deleted file mode 100644
index c2474ae4f1e1..000000000000
--- a/media-sound/drumstick/files/0.5.0-doc_automagicness.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -urN drumstick-0.5.0.old/CMakeLists.txt drumstick-0.5.0/CMakeLists.txt
---- drumstick-0.5.0.old/CMakeLists.txt 2010-09-09 12:38:56.000000000 +0200
-+++ drumstick-0.5.0/CMakeLists.txt 2011-05-13 11:03:30.156962982 +0200
-@@ -143,6 +143,8 @@
- ADD_SUBDIRECTORY(library)
- ADD_SUBDIRECTORY(utils)
- ADD_SUBDIRECTORY(icons)
-+OPTION(WITH_DOC "Build documentation" ON)
-+IF( WITH_DOC )
- IF(${CMAKE_SYSTEM} MATCHES "Linux")
- FIND_PACKAGE(Doxygen)
- IF(DOXYGEN_FOUND)
-@@ -157,6 +159,7 @@
- ENDIF(DOXYGEN_FOUND)
- ADD_SUBDIRECTORY(doc)
- ENDIF(${CMAKE_SYSTEM} MATCHES "Linux")
-+ENDIF( WITH_DOC )
-
- CONFIGURE_FILE(drumstick-alsa.pc.in drumstick-alsa.pc IMMEDIATE @ONLY)
- CONFIGURE_FILE(drumstick-file.pc.in drumstick-file.pc IMMEDIATE @ONLY)
diff --git a/media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch b/media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch
deleted file mode 100644
index 165db470592e..000000000000
--- a/media-sound/drumstick/files/0.5.0-gcc6-narrowing.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix GCC 6 failures caused by -Wnarrowing
-
---- a/utils/buildsmf/buildsmf.cpp
-+++ b/utils/buildsmf/buildsmf.cpp
-@@ -53,8 +53,8 @@
- m_engine->writeKeySignature(0, 2, major_mode); // D major (2 sharps)
-
- // system exclusive event
-- static char gsreset[] = { 0xf0, 0x41, 0x10, 0x42, 0x12,
-- 0x40, 0x00, 0x7f, 0x00, 0x41, 0xf7 };
-+ static char gsreset[] = { (char)0xf0, 0x41, 0x10, 0x42, 0x12,
-+ 0x40, 0x00, 0x7f, 0x00, 0x41, (char)0xf7 };
- m_engine->writeMidiEvent(0, system_exclusive, sizeof(gsreset), gsreset);
-
- // some note events
---- a/utils/testevents/testevents.cpp
-+++ b/utils/testevents/testevents.cpp
-@@ -262,7 +262,7 @@
- dumpEvent(new KeyPressEvent(5, 60, 124));
- dumpEvent(new ChanPressEvent(6, 111));
- dumpEvent(new PitchBendEvent(7, 1234));
-- char sysex[] = {0xf0, 0x41, 0x10, 0x42, 0x12, 0x40, 0, 0x7f, 0, 0x41, 0xf7};
-+ char sysex[] = {(char)0xf0, 0x41, 0x10, 0x42, 0x12, 0x40, 0, 0x7f, 0, 0x41, (char)0xf7};
- dumpEvent(new SysExEvent(QByteArray(sysex, sizeof(sysex))));
- QString text = "This can be a copyright, song name, instrument, lyric...";
- TextEvent te(text, 3);
diff --git a/media-sound/drumstick/files/0.5.0-underlinking.patch b/media-sound/drumstick/files/0.5.0-underlinking.patch
deleted file mode 100644
index 1ec4fd186029..000000000000
--- a/media-sound/drumstick/files/0.5.0-underlinking.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/utils/vpiano/CMakeLists.txt
-+++ b/utils/vpiano/CMakeLists.txt
-@@ -1,3 +1,5 @@
-+find_package(X11 REQUIRED)
-+
- SET(vpiano_forms_SRCS
- vpianoabout.ui
- connections.ui
-@@ -52,7 +54,7 @@
- TARGET_LINK_LIBRARIES(drumstick-vpiano
- ${QT_LIBRARIES}
- ${ALSA_LIBS}
-- ${QT_X11_X11_LIBRARY}
-+ ${X11_X11_LIB}
- drumstick-common
- drumstick-alsa
- )
diff --git a/media-sound/drumstick/files/drumstick-1.0.2-gcc6.patch b/media-sound/drumstick/files/drumstick-1.0.2-gcc6.patch
deleted file mode 100644
index 4bb66e85536f..000000000000
--- a/media-sound/drumstick/files/drumstick-1.0.2-gcc6.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: library/file/qove.cpp
-===================================================================
---- a/library/file/qove.cpp (revision 316)
-+++ b/library/file/qove.cpp (working copy)
-@@ -11356,7 +11356,7 @@
- OVE::MeasureData* measureData = d->ove.getMeasureData(i, j, k);
- QList<OVE::MusicData*> tempoPtrs = measureData->getMusicDatas(OVE::MusicData_Tempo);
-
-- if (k == 0 || (k > 0 && abs(measure->getTypeTempo() - d->ove.getMeasure(k - 1)->getTypeTempo()) > 0.01)) {
-+ if (k == 0 || (k > 0 && std::abs(measure->getTypeTempo() - d->ove.getMeasure(k - 1)->getTypeTempo()) > 0.01)) {
- int tick = d->mtt.getTick(k, 0);
- int tempo = (int) measure->getTypeTempo();
- tempos[tick] = tempo;
-@@ -11739,7 +11739,7 @@
- }
- case OVE::Articulation_Arpeggio: {
- //if( art->getChangeSoundEffect() ) {
-- unsigned int soundEffect = abs(art->getSoundEffect().first) + abs(art->getSoundEffect().second);
-+ unsigned int soundEffect = std::abs(art->getSoundEffect().first) + std::abs(art->getSoundEffect().second);
- int tickAmount = (soundEffect / notes.size()) * ((notes.size() - i) - 1);
- startTick -= tickAmount;
- //}
-Index: utils/testevents/testevents.cpp
-===================================================================
---- a/utils/testevents/testevents.cpp (revision 316)
-+++ b/utils/testevents/testevents.cpp (working copy)
-@@ -262,7 +262,7 @@
- dumpEvent(new KeyPressEvent(5, 60, 124));
- dumpEvent(new ChanPressEvent(6, 111));
- dumpEvent(new PitchBendEvent(7, 1234));
-- char sysex[] = {0xf0, 0x41, 0x10, 0x42, 0x12, 0x40, 0, 0x7f, 0, 0x41, 0xf7};
-+ char sysex[] = {'\xf0', '\x41', '\x10', '\x42', '\x12', '\x40', '\0', '\x7f', '\0', '\x41', '\xf7'};
- dumpEvent(new SysExEvent(QByteArray(sysex, sizeof(sysex))));
- QString text = "This can be a copyright, song name, instrument, lyric...";
- TextEvent te(text, 3);