summaryrefslogtreecommitdiff
path: root/media-sound/dcd
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/dcd')
-rw-r--r--media-sound/dcd/Manifest5
-rw-r--r--media-sound/dcd/dcd-0.95.ebuild25
-rw-r--r--media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch20
-rw-r--r--media-sound/dcd/files/dcd-0.95-makefile.patch6
4 files changed, 38 insertions, 18 deletions
diff --git a/media-sound/dcd/Manifest b/media-sound/dcd/Manifest
index 0b41a9862c1b..29b373e46c26 100644
--- a/media-sound/dcd/Manifest
+++ b/media-sound/dcd/Manifest
@@ -1,4 +1,5 @@
-AUX dcd-0.95-makefile.patch 393 BLAKE2B 69448f327918e15f43d6ccf5312ab10c166acb68e90a429692dce9d9e248d3bf50689caada0e060ede71cdf5cf84ec736ac9a73c2c7491515e5f817195714e83 SHA512 fe2114a891ca1ab16a9ec352b381410ec85c974eb9b2d82acae87e757f62bc4e9b0bf107d0ef7e3dc20b54a50f3fe9655b312498ac0ff173d0d36cb98a009c8d
+AUX dcd-0.95-Wimplicit-function-declaration.patch 367 BLAKE2B 20eb9c178131f22c59c456ff1e4c61ef511bface4316e9dbbcec6d91e7677368a9db9fc5114e238d3d70ff30d0f0e3359b84097c1f9809c1731db4446c7a2582 SHA512 b6b97901432756424062aceea37160b74300117cdec2c8b47e6c728d91c9245c9fa52ce56e7db7fa5e4105ecc09df99d035b8bb528b96e2b23dc4e1b22d88296
+AUX dcd-0.95-makefile.patch 281 BLAKE2B fe9d98c496747d6cd257421aba127c4853a9dd7df024bd24db021cc21d0cb38b51cc4546082917f17be766731cd4eeb854ebb8d0680fee0507b12785f722ce29 SHA512 7762a5f076f48ff5aed005528e242149db25d67cc165f233be8918821ae58127165d920be00121b1a3cf9985dce5aa2064c4b9e0884db99bb221f9ebf0a9e873
DIST dcd-0.95.tar.bz2 33620 BLAKE2B fe5ee6ad882457c4af21740b1667e78e5081841cf31a4c6c5477921ecaa361eb69315b0735200dff9543f2d0c2af5b129f027798f4ac90a795facd8e4a9f632b SHA512 12e9af435ba857e6b3f65881303ff72b349f0645b2649ffb39b17ffa4ab7f16e0f84d385f24cfd32e386185d78abc575cf326a05febfe0acc56b286a64ac6ff2
-EBUILD dcd-0.95.ebuild 668 BLAKE2B 54bc5038e619cfc24d909c446dda1c674ed36549c31bc8678de66dfac7058cd073b1fd7c4293f7d70499bd09615698b26057dc224d1d579af019fb14d33b487f SHA512 401cd33bf67f409902b61fc71a5f597c98715c8095ae398f9afd1f70006c6f2b04685ba99d98bc1faf5716da5b46eb84773887587883c6489fcce19c43c4289c
+EBUILD dcd-0.95.ebuild 624 BLAKE2B ae9edd66089ea3febbc7f8fa4413a77dd44c85018e20950296ec88c41c7326a27ac1fbfdbd7d663726450e424b4decd4e5e83b63c8a9f8d0a23b6f8c6dd60613 SHA512 5d05281ee0a27196961c5efa0a8086db8b11d7228eaf18f47aa92ebfe539689dd1d8fec225037df532f1178513978f1b697f257bda24538438b6de4705e0e373
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-sound/dcd/dcd-0.95.ebuild b/media-sound/dcd/dcd-0.95.ebuild
index 9d4faecdeaa9..0f9f329da3ff 100644
--- a/media-sound/dcd/dcd-0.95.ebuild
+++ b/media-sound/dcd/dcd-0.95.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A simple command-line based CD Player"
HOMEPAGE="http://www.technopagan.org/dcd"
@@ -12,20 +12,21 @@ SRC_URI="http://www.technopagan.org/dcd/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~ppc ppc64 sparc x86"
-IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-makefile.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
src_compile() {
- emake CC="$(tc-getCC)" CDROM="/dev/cdrom" EXTRA_CFLAGS="${CFLAGS}" || die "emake failed"
+ emake \
+ CC="$(tc-getCC)" \
+ CDROM="/dev/cdrom" \
+ EXTRA_CFLAGS="${CFLAGS}"
}
src_install() {
- dobin dcd || die "dobin failed"
+ dobin dcd
+ einstalldocs
doman dcd.1
- dodoc README BUGS ChangeLog
}
diff --git a/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..d3160424fc20
--- /dev/null
+++ b/media-sound/dcd/files/dcd-0.95-Wimplicit-function-declaration.patch
@@ -0,0 +1,20 @@
+--- a/dcd.c
++++ b/dcd.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <getopt.h>
++#include <time.h>
+
+ #define ZERO 0
+ #define MAX_TRACKS 103
+--- a/screenop.c
++++ b/screenop.c
+@@ -10,6 +10,7 @@
+ #include "cdindex.h"
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+
+ void disk_directory(void) {
+ u_char ct = cd_current_track();
diff --git a/media-sound/dcd/files/dcd-0.95-makefile.patch b/media-sound/dcd/files/dcd-0.95-makefile.patch
index b59fedb6180c..c5ea478beb1d 100644
--- a/media-sound/dcd/files/dcd-0.95-makefile.patch
+++ b/media-sound/dcd/files/dcd-0.95-makefile.patch
@@ -1,7 +1,5 @@
-Index: dcd-0.95/Makefile
-===================================================================
---- dcd-0.95.orig/Makefile
-+++ dcd-0.95/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -114,7 +114,7 @@ all: ${PROGS}
$(CC) -c $(CFLAGS) ${EXTRA_CFLAGS} $< -o $@