summaryrefslogtreecommitdiff
path: root/media-sound/csound/csound-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/csound/csound-9999.ebuild')
-rw-r--r--media-sound/csound/csound-9999.ebuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index f9db4411fa0f..b52669444ab9 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -7,7 +7,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit cmake python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
@@ -29,9 +29,8 @@ HOMEPAGE="https://csound.github.io/"
LICENSE="LGPL-2.1 doc? ( FDL-1.2+ )"
SLOT="0"
# java doesn't work atm as it needs to have some variables specified to work, see src_configure
-# mp3 doesnt work as media-sound/lame does not install cmake file
IUSE="+alsa beats chua curl +cxx debug doc double-precision dssi examples
-fltk +fluidsynth hdf5 +image jack keyboard linear lua luajit nls osc portaudio
+fltk +fluidsynth hdf5 +image jack keyboard linear lua luajit mp3 nls osc portaudio
portaudio portmidi pulseaudio python samples static-libs stk test +threads +utils
vim-syntax websocket"
@@ -57,7 +56,6 @@ BDEPEND="
# https://github.com/csound/csound/issues/920
# currently not used deps due to some issues
# java? ( virtual/jdk:* )
-# mp3? ( media-sound/lame )
CDEPEND="
dev-cpp/eigen:3
>=media-libs/libsndfile-1.0.16
@@ -80,6 +78,7 @@ CDEPEND="
luajit? ( dev-lang/luajit:2 )
!luajit? ( dev-lang/lua:0 )
)
+ mp3? ( >=media-sound/lame-3.100-r3 )
osc? ( media-libs/liblo )
portaudio? ( media-libs/portaudio )
portmidi? ( media-libs/portmidi )
@@ -104,6 +103,7 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-6.13.0-xdg-open.patch"
+ "${FILESDIR}/${PN}-6.15.0-lame.patch"
)
pkg_setup() {
@@ -125,6 +125,7 @@ src_configure() {
-DBUILD_BELA=OFF
-DBUILD_BUCHLA_OPCODES=ON
-DBUILD_CHUA_OPCODES=$(usex chua)
+ -DBUILD_COUNTER_OPCODES=ON
-DBUILD_CSBEATS=$(usex beats)
-DBUILD_CUDA_OPCODES=OFF
-DBUILD_CXX_INTERFACE=$(usex cxx)
@@ -141,7 +142,7 @@ src_configure() {
-DBUILD_JAVA_INTERFACE=OFF
-DBUILD_LINEAR_ALGEBRA_OPCODES=$(usex linear)
-DBUILD_LUA_INTERFACE=$(usex lua)
- -DBUILD_MP3OUT_OPCODE=OFF
+ -DBUILD_MP3OUT_OPCODE=$(usex mp3)
-DBUILD_MULTI_CORE=$(usex threads)
-DBUILD_OPENCL_OPCODES=OFF
-DBUILD_OSC_OPCODES=$(usex osc)
@@ -155,6 +156,7 @@ src_configure() {
-DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
-DBUILD_SELECT_OPCODE=ON
-DBUILD_SERIAL_OPCODES=ON
+ -DBUILD_SHARED_LIBS=ON
-DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs "ON" $(usex test))
-DBUILD_STK_OPCODES=$(usex stk)
@@ -167,21 +169,22 @@ src_configure() {
-DBUILD_WINSOUND=OFF
-DFAIL_MISSING=ON
- -DNEED_PORTTIME=OFF
-DNEW_PARSER_DEBUG=$(usex debug)
+ -DREQUIRE_PTHREADS=$(usex threads)
-DUSE_ALSA=$(usex alsa)
- #-DUSE_ATOMIC_BUILTIN=ON
+ -DUSE_ATOMIC_BUILTIN=ON
-DUSE_AUDIOUNIT=OFF # Apple specific
- #-DUSE_COMPILER_OPTIMIZATIONS=ON
+ -DUSE_COMPILER_OPTIMIZATIONS=ON
-DUSE_COREMIDI=OFF # Apple specific
-DUSE_CURL=$(usex curl)
-DUSE_DOUBLE=$(usex double-precision)
-DUSE_FLTK=$(usex fltk)
-DUSE_GETTEXT=$(usex nls)
-DUSE_GIT_COMMIT=ON
- _DUSE_IPMIDI=ON
+ -DUSE_IPMIDI=ON
-DUSE_JACK=$(usex jack)
+ -DUSE_LIB64=$([[ $(get_libdir) == "lib64" ]] && echo "ON" || echo "OFF")
-DUSE_LRINT=ON
-DUSE_PORTAUDIO=$(usex portaudio)
-DUSE_PORTMIDI=$(usex portmidi)
@@ -220,11 +223,6 @@ src_configure() {
-DPYTHON_MODULE_INSTALL_DIR="$(python_get_sitedir)"
)
- # this is needed, otherwise it sets LIBRARY INSTALL DIR: lib
- [[ $(get_libdir) == "lib64" ]] && mycmakeargs+=(
- -DUSE_LIB64=ON
- )
-
cmake_src_configure
}