summaryrefslogtreecommitdiff
path: root/media-sound/cmix/cmix-1.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cmix/cmix-1.6-r1.ebuild')
-rw-r--r--media-sound/cmix/cmix-1.6-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/cmix/cmix-1.6-r1.ebuild b/media-sound/cmix/cmix-1.6-r1.ebuild
new file mode 100644
index 000000000000..91ce5c26b941
--- /dev/null
+++ b/media-sound/cmix/cmix-1.6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="command line audio mixer"
+HOMEPAGE="http://cmix.sourceforge.net/"
+SRC_URI="http://antipoder.dyndns.org/downloads/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#-amd64: 1.6: 'cmix list' gives: MIXER_READ(SOUND_MIXER_OUTSRC): Input/output error
+KEYWORDS="-amd64 ~ppc sparc x86"
+
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin cmix
+ einstalldocs
+}