summaryrefslogtreecommitdiff
path: root/media-sound/cantata/cantata-2.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cantata/cantata-2.3.3.ebuild')
-rw-r--r--media-sound/cantata/cantata-2.3.3.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/media-sound/cantata/cantata-2.3.3.ebuild b/media-sound/cantata/cantata-2.3.3.ebuild
index 0db70f0c745a..db0b51d4e8d8 100644
--- a/media-sound/cantata/cantata-2.3.3.ebuild
+++ b/media-sound/cantata/cantata-2.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PLOCALES="cs da de en_GB es fr hu it ja ko pl pt_BR ru zh_CN"
-inherit cmake-utils gnome2-utils l10n qmake-utils xdg-utils
+inherit cmake-utils l10n qmake-utils xdg
DESCRIPTION="Featureful and configurable Qt client for the music player daemon (MPD)"
HOMEPAGE="https://github.com/CDrummond/cantata"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/CDrummond/${PN}/releases/download/v${PV}/${P}.tar.bz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
IUSE="cdda cddb cdio http-server libav mtp musicbrainz replaygain streaming taglib udisks zeroconf"
REQUIRED_USE="
?? ( cdda cdio )
@@ -24,6 +24,9 @@ REQUIRED_USE="
replaygain? ( taglib )
"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
COMMON_DEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -59,7 +62,6 @@ RDEPEND="${COMMON_DEPEND}
"
DEPEND="${COMMON_DEPEND}
dev-qt/qtconcurrent:5
- dev-qt/linguist-tools:5
"
# cantata has no tests
@@ -105,8 +107,7 @@ src_configure() {
}
pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+ xdg_pkg_postinst
has_version media-sound/mpd || \
elog "An instance of media-sound/mpd, local or remote, is required to set up Cantata."
@@ -116,8 +117,3 @@ pkg_postinst() {
elog "and querying of portable media players"
fi
}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}