summaryrefslogtreecommitdiff
path: root/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audiotools/audiotools-3.1.1-r2.ebuild')
-rw-r--r--media-sound/audiotools/audiotools-3.1.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-sound/audiotools/audiotools-3.1.1-r2.ebuild b/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
index 3d93d632d29e..02b83872ef6f 100644
--- a/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
+++ b/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -82,6 +82,12 @@ python_compile_all() {
emake -C docs
}
+python_compile() {
+ # setuptools is broken with parallel builds
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}
+
python_test() {
cd test || die
"${PYTHON}" test.py || die