summaryrefslogtreecommitdiff
path: root/media-sound/audiotag
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audiotag')
-rw-r--r--media-sound/audiotag/Manifest3
-rw-r--r--media-sound/audiotag/audiotag-0.19-r1.ebuild28
-rw-r--r--media-sound/audiotag/audiotag-0.19.ebuild6
3 files changed, 33 insertions, 4 deletions
diff --git a/media-sound/audiotag/Manifest b/media-sound/audiotag/Manifest
index b179c36843e8..02728aff31df 100644
--- a/media-sound/audiotag/Manifest
+++ b/media-sound/audiotag/Manifest
@@ -1,3 +1,4 @@
DIST audiotag-0.19.tar.bz2 15016 BLAKE2B d650887a72242d1258fa2d60a876a6c5984369074d16e4f9028468f6520b38afad4a5cf92ba5c2a92f7f2a26b1aaf515998fa1a3fbd6d8d49d15074c68940c14 SHA512 a2e117deb78c3141ca1e17a12ee17033eb762fee822187d8aa708715ee4077b120ea2f7acf09d683d9dd292c0826e1152d09286830976b65d08738ced9a0529e
-EBUILD audiotag-0.19.ebuild 659 BLAKE2B f98b137d8ea382fe6fc99e3425c9774bec183a0b8859afed6db0b8da0777a8d338d24c9c3be80051f46defe1eb16f55f872d98a87d02cad6e1d4b6e79c1acab1 SHA512 674d434e500e9d5447e46d8168c5c36469ca962339bbbf5cb384dfb6378a599ee61f7f51ebe3bae528ced23a036d87707f70f3344cedacbc0aee12567742f982
+EBUILD audiotag-0.19-r1.ebuild 728 BLAKE2B c9888c3883078cce26f16ee46b7660b3d85827a8eb70c6c7b553f8f3611224a90b91b27d18867e9eefbbe05e90355ede7ab53628a0bdf7a727921fd7b803357b SHA512 46be83ed69e6498f5ac3f547fccd0d16ef89840d40dc829d8219807f6a735f6f4289fbe84d3b4a3e84cd26efe1204756d81ceee5eaab5bd4a77c3d6e86facd74
+EBUILD audiotag-0.19.ebuild 655 BLAKE2B bee9ba262b9b9cc1ed7e85809c7784432c4d5be4ba0aa637f0d74732cf3422c4c8b2316eebd1128d6d84740787c2634cc9cd985dfc72d566cb9f5749f73a0a09 SHA512 fcf241e9e5645b49605d3172c835cf80068554c1bf6f8ba50411af19389ae746346e0aba76800ed3c8ba777068977ccfabdf08443f9f1f8ced4ee2811c533f9c
MISC metadata.xml 335 BLAKE2B 1ef03cdff887802e47c3e25d41673ea2c25129b2c43129a72d717249da1208b4445d6d03557b2427f6aa6d7f3e34de9bcaf2c696aad214e842dfdc4782a96cb5 SHA512 6652048b2ed7c99882375c57521d9a2a75cd07a8a54ef88ba351f93212e4cfc42a5eca93572b0ef956696d0fae61a741957b146ae048f5a954b0a0954486507a
diff --git a/media-sound/audiotag/audiotag-0.19-r1.ebuild b/media-sound/audiotag/audiotag-0.19-r1.ebuild
new file mode 100644
index 000000000000..ec257e988dea
--- /dev/null
+++ b/media-sound/audiotag/audiotag-0.19-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Command-line tool for mass tagging/renaming of audio files"
+HOMEPAGE="https://github.com/Daenyth/audiotag"
+SRC_URI="https://github.com/downloads/Daenyth/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_install() {
+ dobin ${PN}
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ optfeature "for m4a/mp4 support" media-video/atomicparsley media-video/atomicparsley-wez
+ optfeature "for flac support" media-libs/flac
+ optfeature "for mp3 support" media-libs/id3lib
+ optfeature "for vorbis support" media-sound/vorbis-tools
+}
diff --git a/media-sound/audiotag/audiotag-0.19.ebuild b/media-sound/audiotag/audiotag-0.19.ebuild
index 4d6d53a136b9..0f163d9e904a 100644
--- a/media-sound/audiotag/audiotag-0.19.ebuild
+++ b/media-sound/audiotag/audiotag-0.19.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=0
-DESCRIPTION="A command-line tool for mass tagging/renaming of audio files"
+DESCRIPTION="Command-line tool for mass tagging/renaming of audio files"
HOMEPAGE="https://github.com/Daenyth/audiotag"
SRC_URI="https://github.com/downloads/Daenyth/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 sparc x86"
IUSE="aac flac mp3 vorbis"