summaryrefslogtreecommitdiff
path: root/media-sound/amsynth/amsynth-1.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/amsynth/amsynth-1.5.1-r1.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.5.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/amsynth/amsynth-1.5.1-r1.ebuild b/media-sound/amsynth/amsynth-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..e820000ed8f6
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.5.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools flag-o-matic
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/amsynth/amsynth"
+SRC_URI="https://github.com/${PN}/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+DOCS="AUTHORS README"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ CFLAGS="" \
+ CXXFLAGS="${CXXFLAGS}" \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}