summaryrefslogtreecommitdiff
path: root/media-radio/svxlink/svxlink-15.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/svxlink/svxlink-15.11.ebuild')
-rw-r--r--media-radio/svxlink/svxlink-15.11.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-radio/svxlink/svxlink-15.11.ebuild b/media-radio/svxlink/svxlink-15.11.ebuild
index de0def111eaa..0eac5fc40fef 100644
--- a/media-radio/svxlink/svxlink-15.11.ebuild
+++ b/media-radio/svxlink/svxlink-15.11.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit cmake-utils qt4-r2 user
+inherit cmake-utils eutils qt4-r2 user
CMAKE_USE_DIR="${S}/src"
@@ -34,6 +34,9 @@ pkg_setup() {
}
src_prepare() {
+ # fix compilation problem with newer gcc bug #639592
+ epatch "${FILESDIR}"/${P}-gcc72.patch
+
cmake-utils_src_prepare
# drop deprecated desktop category (bug #475730)
sed -i -e "s:Categories=Application;:Categories=:g" src/qtel/qtel.desktop || die