summaryrefslogtreecommitdiff
path: root/media-radio/cwdaemon/cwdaemon-0.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/cwdaemon/cwdaemon-0.11.0.ebuild')
-rw-r--r--media-radio/cwdaemon/cwdaemon-0.11.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-radio/cwdaemon/cwdaemon-0.11.0.ebuild b/media-radio/cwdaemon/cwdaemon-0.11.0.ebuild
new file mode 100644
index 000000000000..729af17b7068
--- /dev/null
+++ b/media-radio/cwdaemon/cwdaemon-0.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A morse daemon for the parallel or serial port"
+HOMEPAGE="http://cwdaemon.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-radio/unixcw-3.3.1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # provides header info for getaddrinfo() with C99 (bug 569970)
+ append-cppflags -D_GNU_SOURCE
+ econf
+}