summaryrefslogtreecommitdiff
path: root/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/x42-plugins/x42-plugins-20220605.ebuild')
-rw-r--r--media-plugins/x42-plugins/x42-plugins-20220605.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/media-plugins/x42-plugins/x42-plugins-20220605.ebuild b/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
index f57cf56abcb2..103b9d2a203c 100644
--- a/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/x42/x42-plugins.git"
else
- SRC_URI="http://gareus.org/misc/x42-plugins/${P}.tar.xz"
+ SRC_URI="https://gareus.org/misc/x42-plugins/${P}.tar.xz"
KEYWORDS="amd64"
fi
@@ -40,6 +40,11 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/860402
+ # https://github.com/x42/meters.lv2/issues/41
+ filter-lto
+
emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}