summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-extrecmenu
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-extrecmenu')
-rw-r--r--media-plugins/vdr-extrecmenu/Manifest1
-rw-r--r--media-plugins/vdr-extrecmenu/files/extrecmenu.mk127
2 files changed, 0 insertions, 128 deletions
diff --git a/media-plugins/vdr-extrecmenu/Manifest b/media-plugins/vdr-extrecmenu/Manifest
index e0f7be1248c5..4712696581df 100644
--- a/media-plugins/vdr-extrecmenu/Manifest
+++ b/media-plugins/vdr-extrecmenu/Manifest
@@ -1,6 +1,5 @@
AUX dvdarchive-2.3-beta-configfile.patch 234 BLAKE2B 278e6b84029308d99d16b5ed074a28328e95930fced0542dcb07355a214d8551edeb8cd0cce3f771e9be23d1c04936ed41bae92619dda4dabaf08b4f3850f5f1 SHA512 c81893115c3279fa2421dff6a0bed0e74263b1bb04c3745982b91ae431e14397982250cd68a281bf488fc493413c44d8e92e509c83d6ff6b0ff7a6a17eef1949
AUX dvdarchive.conf 633 BLAKE2B 1b70f19dcc9f94d1d3124773d4338c799cfabad2c0cbb0665d1e7f9cb07c914eb7a87cee4a11d77fb49d3d05cff2f7f641d210c5120c27a57c63eababcc35989 SHA512 1b4f7c68f83617d861277a491dbddfdd76b92fbf342d1cfda7cbb958cc77ce19291b8223d65774aafcd22cfcb273913c1122821eb0be97e7423b4842e9237fd0
-AUX extrecmenu.mk 3332 BLAKE2B 068396bec5431b3487d0417b2c7808032027d70a0aea5aba042838f7b5b92fa450cc290535422d78753440688d76b5a4a0a74a4bb32a7517773a7f7a08f39218 SHA512 b8dce9b7a260c3af5537dc3183bc26174f756b0103f44d3981ef3c4bfbcea68f186df72edd625871884efe3716d23ee33db86805ef62ec6c37427cb6470636d4
AUX vdr-extrecmenu-1.2.4_c++11.patch 1039 BLAKE2B a62bf2595d2eb5e6caf2a267f7234ba175e3022ccbcbb8e78f40c91157e58fc0e79310fd5d2a907531668dc2009a328ed7e1878535e3019e5b81003dd155858a SHA512 b19bdae621a0464620435412bb56ea6ca3ab2d319d09b74a45936ee2556e4204fba9660381ba6ec1c54af5a379c049e661a000d655705120bccf061c27dcd6a7
DIST dvdarchive-2.3-beta.sh.gz 3412 BLAKE2B aca97b4c7abcc907f1242482f0f0550cb38fcd357acb9ec6ebc4c978a8f50e9c63fe6fcc2932e426c5d7301f0eaccc5e2f8726e72abafe504e5503528ce782e9 SHA512 18262b1e6749961bae37894649f518f88ad2ca100b83965eb48ce7344bbf4f7bfac9d36c9b9d91744281c00c4b89fa49209cc98ca5d848b46225facf4ef7a48f
DIST vdr-extrecmenu-1.2.4-r2.tar.gz 729966 BLAKE2B 2ec2790cc57db3a9f1d12cdc43eea3e70076ef14d9f0392eb9ab4cda4bf30999a163526416276e661430bf9b684f7d313f5f7193997118e061bf5352c5bbe39a SHA512 d3103e5bc65f968bc4f512195eaa25b04fb5261281d79c7c486fe2532656b8ee7ddc00648d46e92c468b33f95e77c6ce3b2ca67a2debcc0c7021a4b525ac0aa4
diff --git a/media-plugins/vdr-extrecmenu/files/extrecmenu.mk b/media-plugins/vdr-extrecmenu/files/extrecmenu.mk
deleted file mode 100644
index ae68843778f9..000000000000
--- a/media-plugins/vdr-extrecmenu/files/extrecmenu.mk
+++ /dev/null
@@ -1,127 +0,0 @@
-#
-# Makefile for a Video Disk Recorder plugin
-#
-
-# The official name of this plugin.
-# This name will be used in the '-P...' option of VDR to load the plugin.
-# By default the main source file also carries this name.
-
-PLUGIN = extrecmenu
-
-### The version number of this plugin (taken from the main source file):
-
-VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
-
-### The directory environment:
-
-# Use package data if installed...otherwise assume we're under the VDR source directory:
-PKGCFG = $(if $(VDRDIR),$(shell ${PKG_CONFIG} --variable=$(1) $(VDRDIR)/vdr.pc),$(shell ${PKG_CONFIG} --variable=$(1) vdr || ${PKG_CONFIG} --variable=$(1) ../../../vdr.pc))
-LIBDIR = $(call PKGCFG,libdir)
-LOCDIR = $(call PKGCFG,locdir)
-PLGCFG = $(call PKGCFG,plgcfg)
-#
-TMPDIR ?= /tmp
-
-### The compiler options:
-
-export CFLAGS = $(call PKGCFG,cflags)
-export CXXFLAGS = $(call PKGCFG,cxxflags)
-
-### The version number of VDR's plugin API:
-
-APIVERSION = $(call PKGCFG,apiversion)
-
-### Allow user defined options to overwrite defaults:
-
--include $(PLGCFG)
-
-### The name of the distribution archive:
-
-ARCHIVE = $(PLUGIN)-$(VERSION)
-PACKAGE = vdr-$(ARCHIVE)
-
-### The name of the shared object file:
-
-SOFILE = libvdr-$(PLUGIN).so
-
-### Includes and Defines (add further entries here):
-
-INCLUDES +=
-
-DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
-
-ifdef USE_PINPLUGIN
-DEFINES += -DUSE_PINPLUGIN
-endif
-
-DEFINES += -DUSE_VDR_CUTTER
-
-### The object files (add further files here):
-
-OBJS = $(PLUGIN).o mymenurecordings.o mymenueditrecording.o myreplaycontrol.o mymenucommands.o mymenusetup.o tools.o
-
-### The main target:
-
-all: $(SOFILE) i18n
-
-### Implicit rules:
-
-%.o: %.c
- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
-
-### Dependencies:
-
-MAKEDEP = $(CXX) -MM -MG
-DEPFILE = .dependencies
-$(DEPFILE): Makefile
- @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
-
--include $(DEPFILE)
-
-### Internationalization (I18N):
-
-PODIR = po
-I18Npo = $(wildcard $(PODIR)/*.po)
-I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
-I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
-I18Npot = $(PODIR)/$(PLUGIN).pot
-
-%.mo: %.po
- msgfmt -c -o $@ $<
-
-$(I18Npot): $(wildcard *.c)
- xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
-
-%.po: $(I18Npot)
- msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
- @touch $@
-
-$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
- install -D -m644 $< $@
-
-.PHONY: i18n
-i18n: $(I18Nmo) $(I18Npot)
-
-install-i18n: $(I18Nmsgs)
-
-### Targets:
-
-$(SOFILE): $(OBJS)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
-
-install-lib: $(SOFILE)
- install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
-
-install: install-lib install-i18n
-
-dist: $(I18Npo) clean
- @-rm -rf $(TMPDIR)/$(ARCHIVE)
- @mkdir $(TMPDIR)/$(ARCHIVE)
- @cp -a * $(TMPDIR)/$(ARCHIVE)
- @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
- @-rm -rf $(TMPDIR)/$(ARCHIVE)
- @echo Distribution package created as $(PACKAGE).tgz
-
-clean:
- @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
- @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~