summaryrefslogtreecommitdiff
path: root/media-plugins/libvisual-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/libvisual-plugins')
-rw-r--r--media-plugins/libvisual-plugins/Manifest2
-rw-r--r--media-plugins/libvisual-plugins/libvisual-plugins-0.4.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/media-plugins/libvisual-plugins/Manifest b/media-plugins/libvisual-plugins/Manifest
index 32e7033dc279..f65d437493b0 100644
--- a/media-plugins/libvisual-plugins/Manifest
+++ b/media-plugins/libvisual-plugins/Manifest
@@ -1,3 +1,5 @@
DIST libvisual-plugins-0.4.1.tar.bz2 687994 BLAKE2B 5899580c3b4f5959a5105b79565bd69d87973a38c3d860fb480d88a29846d3017b207ec318ffbd4a2e47382207ccd04cb043a99b68e76f0690cf77fa270e8722 SHA512 db80b081615e129d4bea34c7d99af1978bd1b569f4a1f17cfbbe3cadafc954085552c5944198f9c86f43aa367460d3ca5b4e4ea2aacee4f78dce9ff802a80663
+DIST libvisual-plugins-0.4.2.tar.bz2 731700 BLAKE2B 9a803c2b545fe854959043a37123089f4a215fa8139fc72a520f6cffccb004f347709ea68c273dccf60373a957ecd0aaf7ed0fd3319d431c1f65dcfe10432a95 SHA512 16015bad0a898d0990ba9d5a1fe2ab2d649b5db8b965cc00fa62b095033dc8cf27559e79cc49099b5b0a1d679f1f5f6ba9ccf2eac3ac87ebe48da2e64554a568
EBUILD libvisual-plugins-0.4.1.ebuild 1650 BLAKE2B f938c38af3219afe5115a3ce7b2ebb0dc5baae6968ff7b0d103e82eb5ae02a9d8be3128b981fe1fc86c80aa8014c5bcacccd192c97e919a5b8054dd1bc8ad937 SHA512 f07c5943f467615453e77dc9634ba9ce9c434c7037629b73fd0477e6e31e6b47d0a7157a84efd0130307453cbd97c06a42800f6584d2364c796ab12458ca71dc
+EBUILD libvisual-plugins-0.4.2.ebuild 1894 BLAKE2B 9527b2c946b4d33379de2005d73a6a6dd1acac2ee5b8248a12883d2587646535c31c7ead9e99678d3c2e19883062a0cd3a90cde875bf5026afe882dd9dff292a SHA512 d3ba0ea886be29ee7d9e473d221c3acfe988b2b645556ca2a86442a4e0d8bf209fb1bc06099a51c1d74351f04db91e7baffc453c314030fafe4a77f6182c2563
MISC metadata.xml 502 BLAKE2B cdca87d3e30a985550bf0ae3d922a07670553d360128283d789adbf4584d0d3fa5ae339e52901a8e16c5e1650b6414e5f260aca841957f2ed124e7c437c29a14 SHA512 da4595d0e3dc330fabf03183ae7233323eea087b8e4daeb336d6d2e1ee84156d0639a74b41fe742147477442ab5fef2e51c1cf56e06cdba2647f97f0964bf2cd
diff --git a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.2.ebuild b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.2.ebuild
new file mode 100644
index 000000000000..00630b2e9cde
--- /dev/null
+++ b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit multilib-minimal
+
+DESCRIPTION="collection of visualization plugins for use with the libvisual framework"
+HOMEPAGE="http://libvisual.org/"
+SRC_URI="https://github.com/Libvisual/libvisual/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa debug gstreamer gtk jack mplayer opengl portaudio pulseaudio"
+
+RDEPEND=">=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
+ ~media-libs/libvisual-${PV}[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ gstreamer? ( media-libs/gstreamer[${MULTILIB_USEDEP}] )
+ gtk? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+"
+BDEPEND=">=virtual/pkgconfig-0-r1"
+
+DEPEND="${RDEPEND}
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable jack) \
+ $(use_enable gtk gdkpixbuf-plugin) \
+ $(use_enable gstreamer gstreamer-plugin) \
+ $(use_enable alsa) \
+ $(use_enable mplayer) \
+ --enable-inputdebug \
+ $(use_enable opengl gltest) \
+ $(use_enable opengl nastyfft) \
+ $(use_enable opengl madspin) \
+ $(use_enable opengl flower) \
+ $(use_enable debug) \
+ $(use_enable portaudio) \
+ $(use_enable pulseaudio)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name "*.la" -delete || die
+}