summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild')
-rw-r--r--media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild
new file mode 100644
index 000000000000..e66e5e0c87f9
--- /dev/null
+++ b/media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.36-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-base
+inherit gstreamer
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-proto/videoproto-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+
+# xshm is a compile time option of xvideo
+# x is needed to build any X plugins, but we build/install only xv anyway
+GST_PLUGINS_BUILD="x xvideo xshm"
+GST_PLUGINS_BUILD_DIR="xvimage"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+
+ gstreamer_system_link \
+ gst-libs/gst/video:gstreamer-video \
+ gst-libs/gst/interfaces:gstreamer-interfaces
+}