summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch')
-rw-r--r--media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch b/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch
new file mode 100644
index 000000000000..fdcdc7554482
--- /dev/null
+++ b/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch
@@ -0,0 +1,38 @@
+From bde0f119097117cf0256e450af4267a47782260b Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Wed, 13 May 2015 16:23:26 +0200
+Subject: [PATCH] fix faad2 version check
+
+On fedora 22, the output of cpp inserts extra debug comments, which
+makes our regexp for the faad2 version check fail. This in turn causes
+it to compile with the wrong arguments passed which then causes stack
+corruption and crashes.
+
+Fix this by only checking for the version (which should be by itself on
+a single line). This is potentially less safe, it might be possible that
+a similar string would appear in a later version in the header file.
+
+Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4e2823e..c56295e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2050,9 +2050,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
+ AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
+ for minor in 10 9 8 7 6 5 0; do
+ if test x$faad2_minor_version = "x"; then
+- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
++ AC_EGREP_CPP([\"2\.$minor\"$], [
+ #include <$faad_hdr>
+- GST_CHECK_FAAD_VERSION FAAD2_VERSION
++ FAAD2_VERSION
+ ], [
+ faad2_minor_version=$minor
+ ])
+--
+2.4.1
+