summaryrefslogtreecommitdiff
path: root/media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild')
-rw-r--r--media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild b/media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild
index 8e16910403b7..f486656601fd 100644
--- a/media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild
+++ b/media-plugins/gmpc-last-fm/gmpc-last-fm-0.20.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
DESCRIPTION="This plugin fetches artist art from last.fm"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_LASTFM"
@@ -12,13 +12,17 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND=">=media-sound/gmpc-${PV}
- dev-libs/libxml2
- || ( x11-libs/gdk-pixbuf:2[jpeg] x11-libs/gtk+:2[jpeg] )"
+RDEPEND="
+ >=media-sound/gmpc-${PV}
+ dev-libs/libxml2:=
+ || (
+ x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gtk+:2[jpeg]
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- find "${ED}" -name "*.la" -delete || die
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}