summaryrefslogtreecommitdiff
path: root/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/calf/files/calf-9999-fix-build-with-lld.patch')
-rw-r--r--media-plugins/calf/files/calf-9999-fix-build-with-lld.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch b/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
new file mode 100644
index 000000000000..816da77f7d0d
--- /dev/null
+++ b/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
@@ -0,0 +1,26 @@
+From https://github.com/calf-studio-gear/calf/pull/332/commits/bdaaa92dd82e2425e4683b9d496370c5880e3b3e Mon Sep 17 00:00:00 2001
+From: Violet Purcell <vimproved@inventati.org>
+Date: Thu, 21 Sep 2023 19:08:39 -0400
+Subject: [PATCH] Fix build with LLD
+
+LLVM's LLD handles the -retain-symbols-file option (used by
+-export-symbols-regex in libtool) differently from GNU ld, causing
+undefined references during link. This commit removes the
+-export-symbols-regex option from libcalf_la_LDFLAGS since by default
+libtool exports all symbols anyway, so it should not be necessary.
+
+Signed-off-by: Violet Purcell <vimproved@inventati.org>
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -42,7 +42,7 @@ libcalf_la_LIBADD = $(FLUIDSYNTH_DEPS_LIBS) $(GLIB_DEPS_LIBS)
+ if USE_DEBUG
+ libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ else
+-libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static -export-symbols-regex "lv2_descriptor"
++libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ endif
+
+ if USE_LV2_GUI
+--
+2.42.0
+