summaryrefslogtreecommitdiff
path: root/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/audacious-plugins/audacious-plugins-9999.ebuild')
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-9999.ebuild58
1 files changed, 34 insertions, 24 deletions
diff --git a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
index c5831e1e045b..8ca80a9cf2be 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
@@ -17,11 +17,14 @@ HOMEPAGE="https://audacious-media-player.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="aac adplug +alsa ampache bs2b cdda cue ffmpeg flac fluidsynth http gme jack lame libav libnotify libsamplerate
- lirc mms modplug mp3 nls opengl pulseaudio qt5 qtmedia scrobbler sdl sid sndfile soxr speedpitch vorbis wavpack"
+IUSE="aac adplug +alsa ampache bs2b cdda cue ffmpeg flac fluidsynth gtk http gme
+ jack lame libav libnotify libsamplerate lirc mms modplug mp3 nls opengl
+ pulseaudio qtmedia scrobbler sdl sid sndfile soxr speedpitch streamtuner
+ vorbis wavpack"
REQUIRED_USE="
|| ( alsa jack pulseaudio qtmedia sdl )
- ampache? ( qt5 http ) qtmedia? ( qt5 )"
+ ampache? ( http )
+ gtk? ( !ampache !qtmedia !streamtuner )"
# The following plugins REQUIRE a GUI build of audacious, because non-GUI
# builds do NOT install the libaudgui library & headers.
@@ -50,7 +53,7 @@ DEPEND="
dev-libs/dbus-glib
dev-libs/glib
dev-libs/libxml2:2
- ~media-sound/audacious-${PV}[qt5=]
+ ~media-sound/audacious-${PV}[gtk=]
aac? ( >=media-libs/faad2-2.7 )
adplug? ( media-libs/adplug )
alsa? ( >=media-libs/alsa-lib-1.0.16 )
@@ -58,16 +61,27 @@ DEPEND="
bs2b? ( media-libs/libbs2b )
cdda? (
dev-libs/libcdio:=
- dev-libs/libcdio-paranoia
+ dev-libs/libcdio-paranoia:=
>=media-libs/libcddb-1.2.1
)
- cue? ( media-libs/libcue )
+ cue? ( media-libs/libcue:= )
ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
flac? (
>=media-libs/flac-1.2.1-r1
>=media-libs/libvorbis-1.0
)
fluidsynth? ( media-sound/fluidsynth:= )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/libXcomposite
+ x11-libs/libXrender
+ )
+ !gtk? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ opengl? ( dev-qt/qtopengl:5 )
+ )
http? ( >=net-libs/neon-0.26.4 )
jack? (
>=media-libs/bio2jack-0.4
@@ -81,17 +95,6 @@ DEPEND="
modplug? ( media-libs/libmodplug )
mp3? ( >=media-sound/mpg123-1.12.1 )
pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
- !qt5? (
- x11-libs/gtk+:2
- x11-libs/libXcomposite
- x11-libs/libXrender
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- opengl? ( dev-qt/qtopengl:5 )
- )
qtmedia? ( dev-qt/qtmultimedia:5 )
scrobbler? ( net-misc/curl )
sdl? ( media-libs/libsdl2[sound] )
@@ -99,6 +102,7 @@ DEPEND="
sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
soxr? ( media-libs/soxr )
speedpitch? ( media-libs/libsamplerate:= )
+ streamtuner? ( dev-qt/qtnetwork:5 )
vorbis? (
>=media-libs/libogg-1.1.3
>=media-libs/libvorbis-1.2.0
@@ -109,6 +113,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+}
+
src_prepare() {
default
if ! use nls; then
@@ -118,11 +126,10 @@ src_prepare() {
}
src_configure() {
- use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
-
local myeconfargs=(
--enable-mpris2
--enable-songchange
+ --disable-openmpt # not packaged
--disable-oss4
--disable-coreaudio
--disable-sndio
@@ -137,6 +144,10 @@ src_configure() {
$(use_enable flac filewriter)
$(use_enable fluidsynth amidiplug)
$(use_enable gme console)
+ $(use_enable gtk aosd)
+ $(use_enable gtk gtk)
+ $(use_enable gtk hotkey)
+ $(use_enable !gtk qt)
$(use_enable http neon)
$(use_enable jack)
$(use_enable lame filewriter_mp3)
@@ -148,10 +159,6 @@ src_configure() {
$(use_enable mp3 mpg123)
$(use_enable nls)
$(use_enable pulseaudio pulse)
- $(use_enable !qt5 aosd)
- $(use_enable !qt5 gtk)
- $(use_enable !qt5 hotkey)
- $(use_enable qt5 qt)
$(use_enable qtmedia qtaudio)
$(use_enable scrobbler scrobbler2)
$(use_enable sdl sdlout)
@@ -159,11 +166,14 @@ src_configure() {
$(use_enable sndfile)
$(use_enable soxr)
$(use_enable speedpitch)
+ $(use_enable streamtuner)
$(use_enable vorbis)
$(use_enable wavpack)
$(use_with ffmpeg ffmpeg $(usex libav libav ffmpeg))
)
- use qt5 && myeconfargs+=( $(usex opengl --enable-qtglspectrum --disable-qtglspectrum) )
+ use !gtk && myeconfargs+=(
+ $(usex opengl --enable-qtglspectrum --disable-qtglspectrum)
+ )
econf "${myeconfargs[@]}"
}