summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Manifest.gzbin69186 -> 69190 bytes
-rw-r--r--media-libs/libpgf/Manifest2
-rw-r--r--media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch45
-rw-r--r--media-libs/libpgf/libpgf-7.21.7-r2.ebuild58
4 files changed, 105 insertions, 0 deletions
diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index ac078809244c..6f031a9a09bd 100644
--- a/media-libs/Manifest.gz
+++ b/media-libs/Manifest.gz
Binary files differ
diff --git a/media-libs/libpgf/Manifest b/media-libs/libpgf/Manifest
index d3734699f9ba..509fd921a45d 100644
--- a/media-libs/libpgf/Manifest
+++ b/media-libs/libpgf/Manifest
@@ -1,3 +1,5 @@
+AUX libpgf-7.21.7-remove-off64_t.patch 939 BLAKE2B 3446d82705950af3486fd0378c9330d33224cba2176e48c52fd0e1ba32679df8c8b83f6bf0cffab0a263974c2ae8547f4889e6985fbee495bd2dc7a270969468 SHA512 9d34b3445752e523d9e7971256808bd7062dda07ec5fb7c56f16f2474201c33545529885424cb92206f3b7232e0fb8b8de56809132f79160e70601ef28173d17
DIST libpgf-7.21.7.zip 2075722 BLAKE2B 31c5ab5930ef5658ca9b320fa3df94b7d8566467a657df6d255781664a4750d6b5cb7b351c828cad7c60b42f8cb8926c51bb0271d5c51e2484426a15f18b5eb2 SHA512 dbc17d9dce1afbeffb272df0d573059914d2ac79d652d1d43e67c49509fd6e643be8594bbd1a3058a5aa3a9d30db100c6dcf641051345049cf8f9375d49e2799
EBUILD libpgf-7.21.7-r1.ebuild 1185 BLAKE2B 011c77da3a4a53f4e1e2a80ca71bbf13c6dee90c8eb4979f72da7cd40931bd2d55b92900c203675ed713497b8cbfe0df4ff2abfab70b135c3e31b66846d1c995 SHA512 2d5eee0390a2f2a7fe6abe052e77294c2785e10e1f9c6976fec15ad92cf954eee31086b8d5155cad468c0ec965a081567bda8c211a557a199edeb9fdac90c7be
+EBUILD libpgf-7.21.7-r2.ebuild 1236 BLAKE2B 211b69b6817e149ec792b97350b9fb0c3768c60402538deb2d81221bcff1b6083d72a52874382f5c1adb4f374490eab4f20000c6888d0788d620787b5f1db0d4 SHA512 6bcb5ac4dbc822021b642d06a85632fa3be06497a5182fc4cb58fe3186228f1cf7139f359231d33a84c631c1d1fcb934cd13c01c33f0ce9c7c26795f766211c3
MISC metadata.xml 325 BLAKE2B 2dc17e97d5c74f7679dcd00ab589cacc7ed2303413a07de0632abb4a0ede84b60d9ef085f71ff7ec983c8d79d6ca35a3901bdd4d1885e1ddda535d2fd7b7a8a9 SHA512 ce6fce6a25d71afa9a6834a43ccd22e3e6a8855b5963534295b3c8f13e22a817319ed77a5aa6eb441d6f97de31a9bd94065e6e021e8aa87727c0c40d23a9e53e
diff --git a/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch b/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch
new file mode 100644
index 000000000000..9844bd589b94
--- /dev/null
+++ b/media-libs/libpgf/files/libpgf-7.21.7-remove-off64_t.patch
@@ -0,0 +1,45 @@
+https://bugs.gentoo.org/907091
+
+Remove off64_t, add AC_SYS_LARGEFILE to configure.ac instead
+
+--- a/include/PGFplatform.h
++++ b/include/PGFplatform.h
+@@ -341,10 +341,6 @@
+ #define __POSIX__
+ #endif
+
+-#ifndef off64_t
+-#define off64_t off_t
+-#endif
+-
+ #ifndef lseek64
+ #define lseek64 lseek
+ #endif
+@@ -536,7 +532,7 @@
+ return NoError;
+ }
+ #else
+- off64_t ret;
++ off_t ret;
+ if ((ret = lseek64(hFile, 0, SEEK_CUR)) == -1) {
+ return errno;
+ } else {
+@@ -554,7 +550,7 @@
+ return NoError;
+ }
+ #else
+- if ((lseek64(hFile, (off64_t)posOff, posMode)) == -1) {
++ if ((lseek64(hFile, (off_t)posOff, posMode)) == -1) {
+ return errno;
+ } else {
+ return NoError;
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,6 +31,7 @@
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_HEADERS( [config.h] )
+ AC_PROG_CXX
++AC_SYS_LARGEFILE
+
+ dnl Check for doxygen support
+ AC_PATH_PROG([DOXYGEN], [doxygen])
diff --git a/media-libs/libpgf/libpgf-7.21.7-r2.ebuild b/media-libs/libpgf/libpgf-7.21.7-r2.ebuild
new file mode 100644
index 000000000000..1cb3334335d0
--- /dev/null
+++ b/media-libs/libpgf/libpgf-7.21.7-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix
+
+DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
+HOMEPAGE="https://libpgf.org/"
+SRC_URI="https://downloads.sourceforge.net/project/libpgf/libpgf/${PV}/libpgf.zip -> ${P}.zip"
+S="${WORKDIR}/libpgf"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+BDEPEND="
+ app-arch/unzip
+ doc? (
+ app-text/doxygen
+ dev-texlive/texlive-fontutils
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-off64_t.patch
+)
+
+src_prepare() {
+ default
+
+ # configure.ac has wrong version number
+ sed -i "s/7.15.32/${PV}/g" configure.ac || die
+
+ # many files, including configure.ac and Makefile.am, are saved in dos format, causing errors in autotools
+ edos2unix *.{am,ac,in,sh} */*.{am,in}
+
+ # the package does not respect --docdir and installs docs in /usr/share/doc/${PN}
+ sed -i -e 's/\$(DOC_DIR)/$(DESTDIR)@docdir@/' doc/Makefile.am || die
+
+ if ! use doc; then
+ sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto pdf
+ dodoc doc/*.pdf doc/latex/*.pdf
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}